Hector_mapping Scanmatcher_frame arg to be set

asked 2020-07-21 08:49:40 -0600

Rosnoob gravatar image

Hey guys,

I use YouBot and wanted to see, which mapping works better for me. I used Gmapping and i wanted to try Hector_mapping. My YouBot uses 2 Lasers (published on: Laserscan_front AND Laserscan_back). I gitcloned Hectormapping into catkin_ws/src/ and catkin_maked it. No Errors. When I launch youbot_gazebo_robot base.launch and want to launch Hector_mapping (roslaunch hector_mapping mapping_default.launch) it says:

"[ .../mapping_default.launch]" requires the 'scanmatcher_frame' arg to be set

I didnt changed anything in the Hectorfiles.

Im new to ros and i dont know how to set the arg or what it want from me. I saw another Question with a similiard problem, but the Answer didnt helped me out.

I use ROS Kinetic on my VM with Ubuntu 16.04

I hope some of you could Help me, ty <3

edit retag flag offensive close merge delete