ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
1

rviz on ros windows 10

asked 2020-07-11 17:12:03 -0500

wintermute gravatar image

Hello,

Just for kicks I followed instructions at http://wiki.ros.org/Installation/Windows and installed ros-noetic on windows 10. Also tried the new terminal with ROS profile, tested roscore and rostopic. Pretty cool to see Linuxization of Microsoft.

When I tried to launch rviz, it a windows pops up with the following message:

the code execution cannot proceed because image_transport.dll was not found. Reinstalling the program may fix this problem.

followed by the same window that says:

the code execution cannot proceed because resource_retriever.dll was not found. Reinstalling the program may fix this problem.

I think the problem can be solved by installing a package with the choco package manager, but I am not familiar with this, and very little documentation exists.

Any ideas/help/pointers in the right direction greatly appreciated, Best, -C.

edit retag flag offensive close merge delete

Comments

⠀ ⠀ ⠀ ⠀ ⠀ ⠀ ⠀ ⠀

anonymous userAnonymous ( 2021-01-14 12:48:23 -0500 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2020-07-21 12:50:56 -0500

jjholley gravatar image

What's up, @wintermute.

I just had this problem myself - I found that the dlls were installed in C:\opt\ros\noetic\x64\lib. To fix the problem, add that to your path by editing the Path variable in the System Properties. I did this by typing Environmental Variables in the Windows Search bar, selecting 'Edit the sytem environment variables', clicking 'Environment Variables,' then adding it to the Path variable under System Variables.

I think the intended way is the library path gets appended when you run setup.bat. I'm not sure why that's not occurring for either of us, so if I come across a better fix for setup.bat, I'll edit my post.

edit flag offensive delete link more

Comments

@wintermute - update here. Editing system environment variables were helpful for getting rviz to launch, but several plugins may fail to load. I decided to just use melodic by installing via choco: choco upgrade ros-melodic-desktop_full -y --execution-timeout=0

jjholley gravatar image jjholley  ( 2020-07-21 13:48:03 -0500 )edit

thank you for your answer. after some fiddling, I rolled back to melodic as well.

wintermute gravatar image wintermute  ( 2020-08-21 06:31:33 -0500 )edit
0

answered 2021-11-27 13:34:36 -0500

osilva gravatar image

updated 2021-11-27 13:45:02 -0500

Recently I got a new computer, so I decided to give a try on installing ROS Noetic on Windows 10. It's a lot simpler now, but I got annoyed when RViz wouldn't work, I tried many things but all it was needed was a simple update:

set ChocolateyInstall=c:\opt\chocolatey
choco upgrade all -y --execution-timeout=0

I'd recommend to start with this first.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-07-11 17:12:03 -0500

Seen: 4,567 times

Last updated: Nov 27 '21