Ask Your Question
1

find ROS_PACKAGE_PATH

asked 2012-06-04 15:53:37 -0600

rosmaker gravatar image

updated 2016-10-24 09:07:14 -0600

ngrennan gravatar image

my system is ubuntu11.10,installed with ROS( electric) and openni_kinect.

I want to use the mit kinect demo,then I fellow the guide from http://www.ros.org/wiki/openni/Contests/ROS%203D/Customizable%20Buttons

1.I first perform the General Installation.

2.environment is setup, run:

"rosmake impromptu_buttons"

then, terminal display that:

[ rosmake ] Packages requested are: ['impromptu_buttons'] [ rosmake ] Logging to directory/home/jung/.ros/rosmake/rosmake_output-20120604-205316 [ rosmake ] Expanded args ['impromptu_buttons'] to: [] [ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['impromptu_buttons'] [ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

It seems rosmake is unable to find the package. I should add the path to my ROS_PACKAGE_PATH. How I add the path?

edit retag flag offensive close merge delete

Comments

This is identical to your previous question - you should close one or the other. Also, you might want to indicate what you've tried to do on your own to figure this out. Did you read the documentation I linked to in your previous question? What didn't make sense?

lindzey gravatar imagelindzey ( 2012-06-04 16:00:52 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-06-05 01:38:57 -0600

Lorenz gravatar image

If you were following this tutorial, just put all ros packages in the directory ~/ros_workspace.

However, I recommend using rosws. It provides a more structured way to manage local checkouts of ROS repositories and the ROS_PACKAGE_PATH.

edit flag offensive delete link more
-1

answered 2012-06-05 02:37:15 -0600

amittleider gravatar image

updated 2012-06-05 02:38:08 -0600

If you're using electric, run

vim ~/setup.sh

and add the following lines (this is what mine looks like, you may need to change yours slightly)

#!/bin/sh

source /opt/ros/electric/setup.bash

export ROS_ROOT=/opt/ros/electric/ros

export PATH=$ROS_ROOT/bin:$PATH

export PYTHONPATH=$ROS_ROOT/core/roslib/src:$PYTHONPATH

export ROS_PACKAGE_PATH=/opt/ros/electric/stacks:~/ros_workspace:$ROS_PACKAGE_PATH

then, execute

. ~/setup.sh

If you're package is in /opt/ros/electric/stacks or ~/ros_workpace, ROS should be able to find it.

edit flag offensive delete link more

Comments

This is actually not the recommended way of configuring ROS and it will only work for electric and earlier versions. ROS_ROOT, PATH, PYTHON_PATH and ROS_PACKAGE_PATH are already set by /opt/ros/<distro>/setup.bash. For Fuerte, you have to set ROS_WORKSPACE as mentioned in the tutorial.

Lorenz gravatar imageLorenz ( 2012-06-05 02:43:36 -0600 )edit

Deprecated maybe, but this method works in both Fuerte and Groovy for me.

amittleider gravatar imageamittleider ( 2013-08-11 10:43:16 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-06-04 15:53:37 -0600

Seen: 2,217 times

Last updated: Jun 05 '12