Ask Your Question
0

Navigation goal button not working in rviz2 with TEB controller

asked 2020-07-01 20:35:07 -0500

BorgesJVT gravatar image

updated 2020-07-02 18:43:55 -0500

Hi! I have the navigation2 stack working properly, but when I just change the parameters file (nav2_params.yaml) using the DWB https://github.com/ros-planning/navig... for this one https://github.com/rst-tu-dortmund/te..., which is using TEB controller, navigation does not work, with the following ERROR:

I don't know if it is TEB related or controller-server related...Someone can help me? Is there some guide for working with controller-server in ROS2 already?

[spawner_squarbo-3] [INFO] [1593651708.940728510] [entity_spawner]: Done! Shutting down node.
[gazebo-1] [INFO] [1593651709.053430148] [robot2.joint_states]: Going to publish joint [right_wheel_joint]
[gazebo-1] [INFO] [1593651709.053526222] [robot2.joint_states]: Going to publish joint [left_wheel_joint]
[gazebo-1] [INFO] [1593651709.139952948] [robot2.squarbo_diff_drive]: Wheel pair 1 separation set to [0.073000m]
[gazebo-1] [INFO] [1593651709.140024034] [robot2.squarbo_diff_drive]: Wheel pair 1 diameter set to [0.030000m]
[gazebo-1] [INFO] [1593651709.145417447] [robot2.squarbo_diff_drive]: Subscribed to [/robot2/cmd_vel]
[gazebo-1] [INFO] [1593651709.148919671] [robot2.squarbo_diff_drive]: Advertise odometry on [/robot2/odom]
[gazebo-1] [INFO] [1593651709.154762864] [robot2.squarbo_diff_drive]: Publishing odom transforms between [odom] and [base_link]
[gazebo-1] [INFO] [1593651709.154810610] [robot2.squarbo_diff_drive]: Publishing wheel transforms between     [base_link], [left_wheel_joint] and [right_wheel_joint]
[spawner_squarbo-3] response: gazebo_msgs.srv.SpawnEntity_Response(success=True, status_message='SpawnEntity: Successfully spawned entity [robot2]')
[INFO] [spawner_squarbo-3]: process has finished cleanly [pid 494690]
[rviz2-6] [INFO] [1593651715.118528925] [robot1.rviz2]: Waiting for the lifecycle_manager_localization/manage_nodes service...
[rviz2-6] [INFO] [1593651715.119656983] [robot1.rviz2]: Sending lifecycle_manager_localization/manage_nodes request
[rviz2-6] [INFO] [1593651715.119973148] [robot1.rviz2]: Waiting for the lifecycle_manager_navigation/manage_nodes service...
[rviz2-6] [INFO] [1593651715.120877152] [robot1.rviz2]: Sending lifecycle_manager_navigation/manage_nodes request
[lifecycle_manager-16] [INFO] [1593651715.121529092] [robot1.lifecycle_manager_navigation]: Starting managed nodes bringup...
[lifecycle_manager-16] [INFO] [1593651715.121712970] [robot1.lifecycle_manager_navigation]: Configuring controller_server
[lifecycle_manager-10] [INFO] [1593651715.125730476] [robot1.lifecycle_manager_localization]: Starting managed nodes bringup...
[lifecycle_manager-10] [INFO] [1593651715.125835382] [robot1.lifecycle_manager_localization]: Configuring map_server
[map_server-9] [INFO] [1593651715.127445503] [robot1.map_server]: Configuring
[map_server-9] [INFO] [map_io]: Loading yaml file: /home/borgesjvt/ws/squarbo_ws/install/squarbo_simulation/share/squarbo_simulation/maps/squarhold.yaml
[map_server-9] [DEBUG] [map_io]: resolution: 0.05
[map_server-9] [DEBUG] [map_io]: origin[0]: -10
[map_server-9] [DEBUG] [map_io]: origin[1]: -10
[map_server-9] [DEBUG] [map_io]: origin[2]: 0
[map_server-9] [DEBUG] [map_io]: free_thresh: 0.196
[map_server-9] [DEBUG] [map_io]: occupied_thresh: 0.65
[map_server-9] [DEBUG] [map_io]: mode: trinary
[map_server-9] [DEBUG] [map_io]: negate: 0
[map_server-9] [INFO] [map_io]: Loading image_file: /home/borgesjvt/ws/squarbo_ws/install/squarbo_simulation/share/squarbo_simulation/maps/squarhold.pgm
[map_server-9] [DEBUG] [map_io]: Read map /home/borgesjvt/ws/squarbo_ws/install/squarbo_simulation/share/squarbo_simulation/maps/squarhold.pgm: 384 X 384 map @ 0.05 m/cell
[lifecycle_manager-10] [INFO] [1593651715.190485851] [robot1.lifecycle_manager_localization]: Activating map_server
[map_server-9] [INFO] [1593651715.193955878] [robot1.map_server]: Activating
[lifecycle_manager-10] [INFO] [1593651715.198199264] [robot1.lifecycle_manager_localization]: Managed nodes are active
[rviz2-6] [INFO] [1593651715.230118602] [rviz2]: Trying to create a map of size 384 x 384 using 1 swatches
[rviz2-6] [ERROR] [1593651715.239673349] [rviz2]: Vertex Program:rviz/glsl120/indexed_8bit_image.vert Fragment Program:rviz/glsl120/indexed_8bit_image.frag GLSL link result : 
[rviz2-6] active samplers with a different type refer to the same texture image unit
[rviz2-6] Start navigation
[rviz2-6] [ERROR] [1593651725.553264887] [robot1.rviz2]: FollowWaypoints action server is not available. Is the initial pose set?
[rviz2-6] [INFO] [1593651798.603097728] [rviz2]: Setting estimate pose: Frame:map, Position ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-07-03 13:29:02 -0500

johnconn gravatar image

The params file you listed from the TEB repo is from eloquent. A lot of param names have changed since then, which is probably why your're receiving this error. If you're comfortable doing it yourself, then update the TEB yaml file with special emphasis placed on the plugin_lib_names section being correct. Otherwise, file a ticket in the TEB repo saying the param file is not up to date with foxy.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2020-07-01 20:35:07 -0500

Seen: 729 times

Last updated: Jul 03 '20