The following package was not found in <arg default ... />

asked 2020-06-23 18:27:11 -0500

Shurimian gravatar image

updated 2020-06-24 04:47:35 -0500

gvdhoorn gravatar image

Hey guys, I'm currently trying to launch the f1tenth_simulator package but I run into the below error when I try launching the simulator.launch file using

roslaunch simulator.launch

Resource not found: The following package was not found in <arg default="$(find f1tenth_simulator)/maps/levine.yaml" name="map"/>: f1tenth_simulator`

I split the above error into that preformatted code and quotes because the <arg default...=""/> disappears when I leave it entirely as preformatted code or a quote. The path I'm doing this from is:

C:\opt\ros\melodic\catkin_ws\src\f1tenth_simulator>

In case that matters. I'm also doing this on ROS Melodic and windows 10 as my OS, done through the command line. This probably makes the problem a bit more difficult to answer. I'm pretty new to ROS and being on windows isn't helping ;/ thanks in advance.

edit retag flag offensive close merge delete

Comments

Hello there, I had two thoughts: When you launched your command window, did you call c:\opt\ros\melodic\x64\setup.bat? After you built your workspace, did you call devel\setup.bat?

I'm not sure if the f1tenth project has been enabled on Windows. If you are interested in self-driving cars, we've worked with the ar-tu-do project from TU Dartmoth - https://github.com/ms-iot/ros_simulat... to enable Windows (and simulation on Azure with Windows and Linux)

OoeyGUI gravatar image OoeyGUI  ( 2020-06-24 10:39:37 -0500 )edit