Rosserial odom no new message

asked 2020-06-22 17:08:48 -0600

Kevin7909 gravatar image

Hi: I'm using ubuntu 18.04, ros melodic, rosserial, openCM9.04. I have tried two approaches to publish nav_msgs/Odometry odom on a openCM over USB (ACM0) to a laptop.

First approach was to port the turtlebot3 waffle code to the openCM. This works for sending /cmd_vel to the motors through the openCM and the robot does drive. The openCM also publishes tf, joint-states, odom inf to the laptop. Tf publishes valid messages which are calculated from the odom code. Same for joint-states. So I can see linear and angular information updating and also velocity and position on joint-states updating when the traction motors are driven. The issue is that odom shows as being published but has no new messages.

I also tried the rosserial odom example sketch and the tf is published with valid data. I added nav_msgs/Odometry to the code and the laptop shows that the openCM is publishing from tf with valid messages, But rostopic echo /odom is blank and rostopic hz /odom shows 'no new messages' being listed at the update rate of the message. I've gone from 30Hz to 2Hz with no change in output.

The buffer on the openCM is set to 1024, 1024. Buffer size of 512 produced errors. Baudrate was set to both 57600 and 115200.

I have used both ros_lib and turtlebot3_roslib to test. The libraries are slightly different. I have also tried connecting the openCM to the ROS build for the turtlebot 3 on a raspberry pi. Same outcome.

Any ideas what I'm doing wrong?


edit retag flag offensive close merge delete


I am facing the same issue. Did you make any progress? thanks

jacob n gravatar image jacob n  ( 2020-09-07 04:07:58 -0600 )edit

Not yet. Have you found a solution? If so, what did you come up with? Thanks.

Kevin7909 gravatar image Kevin7909  ( 2020-11-30 12:00:56 -0600 )edit