Gazebo install for melodic can't find packages

asked 2020-06-15 15:17:11 -0600

RomulusSam gravatar image

I'm having trouble installing Gazebo9 on my Ubuntu 18.04 machine running ROS Melodic. Whenever I do the recommended install option for Melodic on the tutorial "sudo apt-get install ros-melodic-simulator-gazebo" I get back "Cannot find packages". However, I can download it the indigo recommended way, but I run into the same cannot find packages down the road. Does anyone know how to fix this? I've tried Gazebo9 and Gazebo11, both recommended in different places, but neither have worked. Could it be a compatibility problem? I'm at my wit's end. Please help.

edit retag flag offensive close merge delete

Comments

Whenever I do the recommended install option for Melodic on the tutorial [..]

which tutorial?

Always link to tutorials or web sites you are using as reference. We do not see what you see, so we cannot know what you are trying to do or in what context.

gvdhoorn gravatar image gvdhoorn  ( 2020-06-16 02:40:41 -0600 )edit

Thank you, you are right. This is the link to the download tutorial I am using:

https://dev.px4.io/v1.9.0/en/simulati...

To further clarify, I have Gazebo and Melodic downloaded, but I'm not able to run imported simulations. Specifically, I get stuck at the sitl part of this tutorial. When I try to run it, I get this error

Resource not found: The following package was not found in <arg default="$(find mavlink_sitl_gazebo)/worlds/empty.world" name="world"/>: mavlink_sitl_gazebo ROS path [0]=/opt/ros/melodic/share/ros ROS path [1]=/home/belmont/catkin_ws/src/mavlink ROS path [2]=/home/belmont/catkin_ws/src/mavros/libmavconn ROS path [3]=/home/belmont/catkin_ws/src/mavros/mavros_msgs ... ROS path [9]=/home/bel The traceback for the exception was written to the log file

I downloaded the recommended Firmware folder from the link, but I suspect I put it ...(more)

RomulusSam gravatar image RomulusSam  ( 2020-06-16 10:00:16 -0600 )edit