ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Error running Turtlesim noetic

asked 2020-06-12 17:57:23 -0500

chm007 gravatar image

Good Afternoon All,

I am going through the tutorial at : I ran the command : rosrun turtlesim turtlesim_node and it generated the error :

/opt/ros/noetic/lib/turtlesim/turtlesim_node: error while loading shared libraries: cannot open shared object file: No such file or directory

I verified that is installed, and idea on how to resolve? Please advise?


edit retag flag offensive close merge delete


This doesn't seem to be an issue with ROS, but rather with your system. See here for example. If that doesn't help, can you provide system details?

achille gravatar image achille  ( 2020-06-12 21:07:44 -0500 )edit

Im trying to install ros/gazebo using WSL in ubuntu 20.4 and getting the same error. any clue to fix this?

chethw gravatar image chethw  ( 2021-06-16 20:21:40 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2021-08-11 21:49:36 -0500

KindlyAccept gravatar image


I have solved the same problem.

Maybe this problem is due to the version of WSL in ubuntu 20.04.

To solve this problem, refer to this URL: link text

# copy that address
sudo strip --remove-section=.note.ABI-tag /usr/lib/x86_64-linux-gnu/

Good Luck.

edit flag offensive delete link more


This worked thanks

chm007 gravatar image chm007  ( 2022-03-25 06:45:39 -0500 )edit

Question Tools

1 follower


Asked: 2020-06-12 17:57:23 -0500

Seen: 9,602 times

Last updated: Jun 12 '20