Ask Your Question
0

TF lookup extrapolate into the future

asked 2020-05-21 16:40:16 -0500

MakinoharaShouko gravatar image

updated 2020-05-22 03:50:53 -0500

gvdhoorn gravatar image

I am trying to implement the navigation stack on my robot but got the following error

[ERROR] [1590093633.840344045]: Extrapolation Error: Lookup would require extrapolation into the future.  Requested time 1590093633.865389378 but the latest data is at time 1590093633.848809827, when looking up transform from frame [odom] to frame [map]

Here are the commands I am using to launch the static tf publishers

<node pkg="tf" type="static_transform_publisher" name="link1_broadcaster" args="0 0 0 0 0 0 1 map odom 100" />  
<node pkg="tf" type="static_transform_publisher" name="link2_broadcaster" args="0 0 0 0 0 0 1 odom base_link 100" />  
<node pkg="tf" type="static_transform_publisher" name="link3_broadcaster" args="0 0 0.1 0 0 0 1 base_link zed_camera_center 100" />

All my nodes are running on the same machine so I do not think that time synchronization is the problem. I am not using map_server or amcl either. I am wondering what other factors can cause that

edit retag flag offensive close merge delete

Comments

You can try to increase transform_tolerance param. Increase the static_tf_publisher rate as well. Now you only pub at 10Hz

tianb03 gravatar image tianb03  ( 2020-05-22 05:48:35 -0500 )edit

I have already increased the transform_tolerance to 2.0 but it did not help. And my robot fails to meet the control loop frequency when the static_tf_publisher rate is increased.

MakinoharaShouko gravatar image MakinoharaShouko  ( 2020-05-22 13:23:39 -0500 )edit

I don't think the static tf affects your control frequency. Actually your data and the requested data only has a very small difference 0.02s, my suggestions may be wrong. For the correct params, you should only adjust a little bit will do

tianb03 gravatar image tianb03  ( 2020-05-23 02:26:14 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-04-28 01:21:56 -0500

I also have this problem . how I resolve this? Actually I just replace the parameters file of movebase. I recommond you to use the setup files of movebase from official simulation demo of turtlebot.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-05-21 16:20:29 -0500

Seen: 208 times

Last updated: May 22 '20