How to set "height_map" to false in octomap_server?

asked 2020-05-19 11:56:13 -0600

chenyumingx gravatar image

Hi everyone! Here is my launch file,I want to create the octomap by calling "octomap_server" from this launch file. "height_map" defaults to "true",it mens octomap with heigth color. but I don't want to create octomap with heigth color.I've set “height_map” to "false" in my launch file,however,The octomap still has height color Here is wiki about "octomap_server": http://wiki.ros.org/octomap_server Many thanks!!!

<launch>
<node pkg="octomap_server" type="octomap_server_node" name="octomap_server">

<!-- resolution in meters per pixel -->
<param name="resolution" value="0.05" />

<!-- name of the fixed frame, needs to be "/map" for SLAM -->
<param name="frame_id" type="string" value="/world" />

 <!-- height_map (bool, default: true) Whether visualization should encode height with different colors -->
 <param name="height_map" value="false" />


 <!-- max range / depth resolution of the kinect in meter -->
 <param name="sensor_model/max_range" value="100.0" />
 <param name="latch" value="true" />

 <!-- max/min height for occupancy map, should be in meters -->
 <param name="pointcloud_max_z" value="1000" />
 <param name="pointcloud_min_z" value="-100" />

 <!-- topic from where pointcloud2 messages are subscribed -->
 <remap from="/cloud_in" to="/output" />

 </node>

 <node pkg="rviz" type="rviz" name="$(anon rviz)" respawn="false" output="screen" args="-d $(find publish_pointcloud)/rviz/mapping.rviz"/>

 </launch>
edit retag flag offensive close merge delete