Ask Your Question
1

Could not select device driver "" with capabilities: [[gpu]].

asked 2020-05-14 18:04:06 -0500

Description

I have been trying to install and setup ADE using the .aderc file, but I get a GPU-related error. I post this here as one owner of the AutowareAuto repository in GitLab told me in the comment of the issue I opened.

How to reproduce

I am using Kubuntu 18.04 (bionic) and have installed Docker 19.03 successfully (I can execute docker run hello-world). I have followed the Quick Start section of the first lesson of the Autoware.Auto course. I am using a Laptop and have tried to do it both with and without the dedicated GPU activated, which is an NVidia GTX 1060 6GB (the integrated one is the one of the Intel i7 8750H). I would like to have this running while being able to use the GTX.

I have already searched updates for the NVidia drivers and tried to update everything in my system.

Current Behavior

I get the following error:

$ cd adehome/AutowareAuto/

$ ade start
Starting ade with the following images:
ade          | 18425565a9fd | master | registry.gitlab.com/autowarefoundation/autoware.auto/autowareauto/ade:master
ade-atom     | v1.39.1      | latest | registry.gitlab.com/apexai/ade-atom:latest                                                                                                                                                            
autowareauto | c9745bf2663e | master | registry.gitlab.com/autowarefoundation/autoware.auto/autowareauto:master                                                                                                                              
ade_registry.gitlab.com_apexai_ade-atom_latest                                                                                                                                                                                               
ade_registry.gitlab.com_autowarefoundation_autoware.auto_autowareauto_master                                                                                                                                                                 
docker: Error response from daemon: could not select device driver "" with capabilities: [[gpu]].                                                                                                                                            
ERROR: Command return non-zero exit code (see above): 125                                                                                                                                                                                    
  docker run -h ade --detach --name ade --env COLORFGBG --env DISPLAY --env EMAIL --env GIT_AUTHOR_EMAIL --env GIT_AUTHOR_NAME --env GIT_COMMITTER_EMAIL --env GIT_COMMITTER_NAME --env SSH_AUTH_SOCK --env TERM --env TIMEZONE=Europe/Paris --env USER=jmtc7 --env GROUP=jmtc7 --env USER_ID=1000 --env GROUP_ID=1000 --env VIDEO_GROUP_ID=44 -v /dev/dri:/dev/dri -v /dev/shm:/dev/shm -v /tmp/.X11-unix:/tmp/.X11-unix -v /home/jmtc7/adehome:/home/jmtc7 --env ADE_CLI_VERSION=4.1.0 --env ADE_HOME_HOSTPATH=/home/jmtc7/adehome --label ade_version=4.1.0 -v /home/jmtc7/.ssh:/home/jmtc7/.ssh -v /tmp/ssh-AsnCiCzQcdnx/agent.1739:/tmp/ssh-AsnCiCzQcdnx/agent.1739 --volumes-from ade_registry.gitlab.com_apexai_ade-atom_latest:ro --volumes-from ade_registry.gitlab.com_autowarefoundation_autoware.auto_autowareauto_master:ro --label 'ade_volumes_from=["ade_registry.gitlab.com_apexai_ade-atom_latest", "ade_registry.gitlab.com_autowarefoundation_autoware.auto_autowareauto_master"]' --gpus all --env NVIDIA_VISIBLE_DEVICES=all --env NVIDIA_DRIVER_CAPABILITIES=compute,utility,graphics,display --env LD_LIBRARY_PATH=/usr/local/nvidia/lib64 --cap-add=SYS_PTRACE --env ADE_IMAGE_ADE_FQN=registry.gitlab.com/autowarefoundation/autoware.auto/autowareauto/ade:master --env ADE_IMAGE_ADE_COMMIT_SHA=18425565a9fdfd2b5e9a8fd837f18f8bbd99d961 --env ADE_IMAGE_ADE_COMMIT_TAG= --env ADE_IMAGE_ADE_ATOM_FQN=registry.gitlab.com/apexai/ade-atom:latest --env ADE_IMAGE_ADE_ATOM_COMMIT_SHA=41a804c93041bf2ef4fe118676a4b6a84bdeff91 --env ADE_IMAGE_ADE_ATOM_COMMIT_TAG=v1.39.1 --env ADE_IMAGE_AUTOWAREAUTO_FQN=registry.gitlab.com/autowarefoundation/autoware.auto/autowareauto:master --env ADE_IMAGE_AUTOWAREAUTO_COMMIT_SHA=c9745bf2663ecca9d73c20e29d8c4624b58948f5 --env ADE_IMAGE_AUTOWAREAUTO_COMMIT_TAG= --label 'ade_images=[{"fqn": "registry.gitlab.com/autowarefoundation/autoware.auto/autowareauto/ade:master", "commit_sha": "18425565a9fdfd2b5e9a8fd837f18f8bbd99d961", "commit_tag": ""}, {"fqn": "registry.gitlab.com/apexai/ade-atom:latest", "commit_sha": "41a804c93041bf2ef4fe118676a4b6a84bdeff91", "commit_tag": "v1.39.1"}, {"fqn": "registry.gitlab.com/autowarefoundation/autoware.auto/autowareauto:master", "commit_sha": "c9745bf2663ecca9d73c20e29d8c4624b58948f5", "commit_tag": ""}]' registry.gitlab.com/autowarefoundation/autoware.auto/autowareauto/ade:master

Some further information about my installations and system:

$ which ade
/home/jmtc7/.local/bin/ade

$ nvidia-smi
Wed May 13 20:31:59 2020       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 440.82       Driver Version: 440.82       CUDA Version: 10.2     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-05-15 04:28:09 -0500

Solved. Solution:

In case someone finds himself in the same situation, I just followed the installation for NVIDIA Docker. It seems Docker 19.03 does not really work with GPUs by itself as I misunderstood... At least not for me. For convenience, these are the installation commands for Ubuntu/Debian:

# Add the package repositories
distribution=$(. /etc/os-release;echo $ID$VERSION_ID)
curl -s -L https://nvidia.github.io/nvidia-docker/gpgkey | sudo apt-key add -
curl -s -L https://nvidia.github.io/nvidia-docker/$distribution/nvidia-docker.list | sudo tee /etc/apt/sources.list.d/nvidia-docker.list

sudo apt-get update
sudo apt-get install -y nvidia-container-toolkit
sudo systemctl restart docker
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-05-14 18:04:06 -0500

Seen: 3,141 times

Last updated: May 14 '20