Ask Your Question
0

Intel Realsense: Time is out of Dual 32-bit range

asked 2020-04-24 04:38:04 -0500

DJac gravatar image

updated 2020-04-24 05:50:25 -0500

gvdhoorn gravatar image

We are trying to get the Intel Realsense D435i to work on our Raspberry Pi with the Raspbian OS and ROS Melodic.

After we configured our Raspberry Pi with Raspbian and installed ROS Melodic on it, we installed the realsense-ros package on our Raspberry Pi. When we connect our Realsense camera to the Raspberry and run the following command:

$ roslaunch realsense2_camera rs_camera.launch

The following error is published constantly:

An error has occured during frame callback: Time is out of Dual 32-bit range

We get some ros topics from the camera but they don't publish any data. Also not all of the topics are displayed. When we plug the camera in to a pc it works fine.

We already googled it and tried the following:

  • full clean and rebuild of catkin workspace
  • update and upgrade of all ros packages
  • delete ros_comm package

But non off the above worked for us.

Is there anybody who has any ideas?

Thanks in advance!

edit retag flag offensive close merge delete

Comments

I'm sorry to have to do this for something so seemingly unimportant, but please don't post screenshots of terminal text in question on ROS Answers. It's all text, so there is no need. Just copy-paste the text from the terminal into your question text. Do make sure to format it properly by selecting the text and pressing ctrl+k (or clicking the Preformatted Text button (the one with 101010 on it)).

You don't need to post a new question, just edit your curent one. You can use the edit button/link for this.

After you replace the screenshot with the error message itself, we can re-open your question.

gvdhoorn gravatar image gvdhoorn  ( 2020-04-24 05:02:35 -0500 )edit

I've re-opened it, but for future questions: please always include a verbatim copy-paste (ie: the complete error message). Context is important.

gvdhoorn gravatar image gvdhoorn  ( 2020-04-24 05:52:31 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-06-01 14:49:30 -0500

GC gravatar image

Try to de-activate in the launch file your IMU. Set the enable_gyro and enable_accel to false.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2020-04-24 04:38:04 -0500

Seen: 67 times

Last updated: Jun 01