Ask Your Question
1

Octomap with ubuntu 11.10

asked 2012-05-28 06:36:12 -0500

Chong gravatar image

updated 2012-05-28 07:01:18 -0500

Kevin gravatar image

I'm using ROS electric and I am following the tutorial here and I got a problem when I run

rosdep install octomap_mapping
I guess it's because I didn't rightly "add the source directory to your ROS_PACKAGE_PATH (e.g. in ~/.bashrc), source that file" but I am new to ubuntu and ROS so I don't know what's the right way doing it. Can anybody give me detailed instructions? Thanks a lot !

By the way, the error message I got after I run

rosdep install octomap_mapping
is

chong@ubuntu:~/rospkg$ rosdep install octomap_mapping
Failed to find rosdep octomap for package octomap on OS:ubuntu version:oneiric
rosdep install ERROR:
failed to install octomap

and my .bashrc has the following related lines:

source /opt/ros/electric/setup.bash
export ROS_PACKAGE_PATH=~/rospkg:$ROS_PACKAGE_PATH
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-05-28 09:27:31 -0500

AHornung gravatar image

Apparently you are using ROS electric, with the trunk of octomap_mapping from SVN. I just recently changed the trunk to build against fuerte, and that requires an "octomap" system package as rosdep (ros-fuerte-octomap).

Just use the electric branch of octomap:

svn co http://alufr-ros-pkg.googlecode.com/svn/branches/octomap_mapping-electric/ octomap_mapping

or the bre-built binary packages as joq suggested. Alternatively, you can also upgrade to the latest ROS fuerte.

edit flag offensive delete link more

Comments

Thanks.It seems to work.But how about octovis?Is it automatically installed with ocotomap_mapping or I have to separately install it somewhere? And could you please give specific instructions on how to install ocotomap_mapping under electric? I'm new to ubuntu so I am worried if I mess up something.

Chong gravatar image Chong  ( 2012-06-03 10:01:18 -0500 )edit

See @joq's answer on how to install the package pre-compiled, you don't need to check something out and compile then.

AHornung gravatar image AHornung  ( 2012-06-03 22:33:08 -0500 )edit

octovis as GUI is not installed by default with the library. If you upgrade to ROS fuerte, you can install the octovis package with "sudo apt-get install ros-fuerte-octovis". For electric, you need to download the complete octomap package (non-ros) from octomap.sf.net and compile yourself.

AHornung gravatar image AHornung  ( 2012-06-03 22:34:33 -0500 )edit

I see. Thanks. One more question: if I use the non-ros version of octovis, is it still possible to view the colored map? Cuz when i use that to open the filename.bt, i can only see the depth map with no colors

Chong gravatar image Chong  ( 2012-06-04 09:47:21 -0500 )edit

Yes, any recent version of octovis can display colored maps. But they have to be in a .ot file, .bt files do not contain color information. See http://ais.informatik.uni-freiburg.de/projects/datasets/octomap/ for details and example files.

AHornung gravatar image AHornung  ( 2012-06-04 22:31:37 -0500 )edit

Thanks. I'm trying to use rgbdslam package to work with octomap. it seems rgbdslam package cannot save as .ot file. it can only save as pcd file.

Chong gravatar image Chong  ( 2012-06-07 10:04:35 -0500 )edit

I downloaded the non-ros package and compiled the whole package myself. But, I don't know how to open the octovis GUI to view the built map. I tried $ octovis in terminal. But it says command not found.

Sudhan gravatar image Sudhan  ( 2012-07-29 22:15:17 -0500 )edit
0

answered 2012-05-28 07:51:21 -0500

joq gravatar image

Did you try installing the binary package?

sudo apt-get install ros-electric-octomap-mapping
edit flag offensive delete link more

Comments

tried. still not working. and on the wiki page (http://www.ros.org/wiki/octomap_mapping) it uses "sudo apt-get install ros-fuerte-octomap" and "sudo apt-get install ros-fuerte-octomap ros-fuerte-octomap-mapping"

Chong gravatar image Chong  ( 2012-05-28 09:21:27 -0500 )edit

These are the instructions for ROS electric, the wiki is for the latest version (fuerte). If you use these instructions, you don't need to compile octomap_mapping yourself at all, but you'll have it installed system-wide.

AHornung gravatar image AHornung  ( 2012-05-28 09:30:41 -0500 )edit

We need specific information in order to solve problems. Please edit your question, showing exactly what happens when you run the command above.

joq gravatar image joq  ( 2012-05-28 11:10:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-05-28 06:36:12 -0500

Seen: 746 times

Last updated: May 28 '12