Ask Your Question
2

rosserial does not work on Ubuntu 11.10 Oneiric

asked 2011-10-20 22:13:57 -0600

I installed Ubuntu 11.10 and tried to install ros. Only the ros-electric-common could be installed (not the desktop version) but I thought this may be enough for rosserial (To try with my Arduino communication).

But there is a dependancy-problem. Could not install rosserial because I was missing geometry, which can not be loaded because the package libglut3-dev is replaced by freeglut3-dev (see ticket 4963 from 5 months ago).

Could a developer change this dependency please, or give me a workaround for this problem, so I can use my Arduino with ROS. This was the only dependency that was NOK so this would help me very much

edit retag flag offensive close merge delete

Comments

4 Answers

Sort by » oldest newest most voted
1

answered 2011-10-21 06:53:15 -0600

fergs gravatar image

updated 2011-10-21 06:57:32 -0600

Debs are still building for much of 11.10 -- these issues will get worked out.

Also, for future note, it is probably more helpful to note that you have a problem with "geometry" not "rosserial". rosserial is one of many, many packages that depend on geometry, but the rosserial developers are not going to be able to help you fix a problem with geometry building (and geometry is a legitimate dependency of rosserial).

If you want to temporarily build rosserial on a broken ROS install, you could do the following:

  1. Do a source checkout of rosserial (using hg).
  2. Edit rosserial_arduino/CMakeLists.txt and rosserial_arduino/manifest.xml to remove references to geometry_msgs.
  3. Run "make" in that local folder (make sure rosserial is on your ROS package path).

Note that none of the examples that use geometry_msgs will work.

edit flag offensive delete link more
1

answered 2011-10-23 21:32:30 -0600

There are two main broken dependencies for installing electric (with the natty repository) in oneiric:

libglut3-dev (needed for geometry funcionality) libopencv2.3-dev (needed for vision functionality)

The first one can be easily (and temporally)solved installing manually libglut3-dev: https://launchpad.net/ubuntu/oneiric/+package/libglut3-dev

Then electric-desktop and some basic functionality can be installed. However the electric-desktop-full cannot be installed due to the second broken dependency. A temporal solution can be install libopencv2.3-dev from some ppa like: https://launchpad.net/~gijzelaar/+archive/opencv2.3

Regards.

edit flag offensive delete link more
1

answered 2011-10-26 00:06:52 -0600

sebsch gravatar image

There is a workaround. I described what worked for me here.

Hope this helps.

edit flag offensive delete link more
0

answered 2011-10-21 05:16:38 -0600

Enrique gravatar image

I also installed Ubuntu 11.10 (server i386) and ros-electric-* and found the same problem when trying to install ros-electric-camera-drivers, which also depends on geometry. Note that I use natty (Ubuntu 11.04) repos.

I think geometry depends on bullet (I don't have access to the system right now) for some reason, and this depends on libglut3 (removed in Ubuntu 11.10) instead of freeglut3. Had that dependency changed would probably solve the problem, but I don't see why I should have graphical packages installed in a server (tty) system. Maybe, that dependency with geometry or bullet should be removed.

best

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-20 22:13:57 -0600

Seen: 934 times

Last updated: Oct 26 '11