ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Problem with Rviz with Planning Description Configuration Wizard

asked 2012-05-28 05:20:09 -0600

Robin C gravatar image

updated 2014-01-28 17:12:29 -0600

ngrennan gravatar image

Hi everybody,

I would like to create an interface to control a 6 dof arm. I would like at least something that enables me to reach a goal position by entering the coordinates (with an IK solver). I'm begining with ROS and I thought at first time to use the "Planning Description Configuration Wizard" which autogenerate all the needed files to create a planner. But I dealed with some difficulties.

When I launch:

roslaunch planning_environment planning_description_configuration_wizard.launch urdf_package:=modular_arm urdf_path:=ros/robots/modular_arm_PG.urdf.xacro

The Wizard and Rviz are launching without any error but only the base_link of my model appears. I can't identify where this problem belongs. When I load my model in gazebo and do "rosrun rviz rviz" in another terminal, evrything goes well with the model in Rviz but I can't see the links in the Wizard.

Here are the xacro.urdf of my model:

<?xml version="1.0"?>
<robot xmlns:sensor=""
       name="modular_arm" >

  <!-- The following included files set up definitions of parts of the robot body -->
  <!-- misc common stuff? -->
  <include filename="$(find modular_arm)/ros/urdf/common.xacro" />

  <include filename="$(find modular_arm)/ros/calibration/modular_arm.urdf.xacro" />

  <!-- cob arm-->
  <include filename="$(find modular_arm)/ros/urdf/modular_arm.urdf.xacro" />

  <!-- PG -->
  <include filename="$(find modular_arm)/ros/urdf/PG.urdf.xacro" />

  <!-- generic simulator_gazebo plugins for starting mechanism control, ros time, ros battery -->
  <include filename="$(find modular_arm)/ros/gazebo/gazebo.urdf.xacro" />

  <!-- materials for visualization -->
  <include filename="$(find modular_arm)/ros/urdf/materials.urdf.xacro" />

  <!-- foot for arm-->
    <link name="base_link">
        <!--origin xyz="0 0 0.1" rpy="0 0 0"--> 
           <origin xyz="0 0 0.474" rpy="0 0 0"/>
           <mass value="100.0"/>
           <inertia ixx="10.0"  ixy="0"  ixz="0" iyy="100.0" iyz="0" izz="100.0" />

        <!--origin xyz="0 0 0.1" rpy="0 0 0"--> 
           <origin xyz="0 0 0.474" rpy="0 0 0" />
            <mesh filename="package://modular_arm/ros/meshes/frame.stl" scale="0.001 0.001 0.001" />
        <material name="Grey">
        <color rgba="0.7 0.7 0.7 1.0"/>

        <!--origin xyz="0 0 0.1" rpy="0 0 0"--> 
           <origin xyz="0 0 0.474" rpy="0 0 0" />
             <mesh filename="package://modular_arm/ros/meshes/frame.stl" scale="0.001 0.001 0.001" />

  <!-- arm -->
  <xacro:cob_arm_v0 name="arm" parent="base_link">  
    <origin xyz="0 0 0.474" rpy="0 3.14159265 1.570796325" />

  <!-- sdh -->
  <!--xacro:cob_sdh_v0 name="sdh" parent="arm_6_link">
    <origin xyz="0 -0.0595 0" rpy="1.57079633 0 0 " />

  <!-- PG -->
  <xacro:PG name="PG" parent="arm_6_link">
    <!--origin xyz="0 -0.0595 0" rpy="0 0 0"/-->
    <origin xyz="0 0 0" rpy="-1.570796325 3.14159265 0"/>


<?xml version="1.0"?>
<robot  xmlns ...
edit retag flag offensive close merge delete


I'm working on the modular arm of Robotnik. All the parameters aren't fixed yet. I think the problem belongs to the format of my urdf. The Planning Description Wizard tutorial suggest that I should fully expand my .xacro to the .xml format but I really don't know how to do.

Robin C gravatar image Robin C  ( 2012-05-29 02:28:58 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2012-05-31 05:51:01 -0600

egiljones gravatar image

You are correct that trying to pass in xacro is not working - the URDF parser will just ignore everything that's in xacro, which is why you are only getting your base link, as that's in urdf. To convert from xacro to urdf run the following command:

rosrun xacro my_robot.xacro > my_robot.urdf

Replacing my_robot, of course, and then run the wizard with my_robot.urdf .

edit flag offensive delete link more

answered 2012-06-06 03:14:33 -0600

Robin C gravatar image

Thank you very much egiljones! It's work perfectly! Meanwhile I found out another way but much more complicated!

I've seen before this command but I wanted wrongly to convert it in a .xml file and not a .urdf. I think this command line should be added to the Planning Description Configuration Wizard tutorial to avoid misunderstandings.

edit flag offensive delete link more

Question Tools


Asked: 2012-05-28 05:20:09 -0600

Seen: 723 times

Last updated: Jun 06 '12