Ask Your Question
1

Need help with roslaunch openhrp3 falling-box.launch !! [closed]

asked 2012-05-25 18:45:28 -0500

TurtleBot_Fan gravatar image

updated 2014-01-28 17:12:27 -0500

ngrennan gravatar image

When I execute: roslaunch openhrp3 falling-box.launch ----Eclipse is invoked and I see the IDE but the start button(s) is disabled. When I use menu GrxUI->Start Simulation, the Graph tab shows 3 windows that seem to be working. The 3D view tab does not have any falling boxes in it. The 3D view tab is blank. What should I do? Also, when I click on the falling-boxes.launch link on the http://code.google.com/p/rtm-ros-robotics/wiki/ROS_English page, I get:

Google

  1. That’s an error.

The requested URL /p/rtm-ros-robotics/source/browse/tags/latest/rtmros_common/openhrp3/launch/faling-boxes.launch was not found on this server. That’s all we know.

Also, here is the transcript of the terminal messages: sam@Mecha:~$ roslaunch openhrp3 falling-box.launch ... logging to /home/sam/.ros/log/2faa415a-a6ec-11e1-a8e5-406186e58fd3/roslaunch-Mecha-22078.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://Mecha:53041/

SUMMARY

PARAMETERS * /rosversion * /rosdistro

NODES / rtm_naming (openrtm/rtm-naming-restart) hrpsys_kill_all (openhrp3/openhrp-shutdown-servers) grxui (openhrp3/grxui.sh)

WARNING: unrecognized tag sphinxdoc ROS_MASTER_URI=http://localhost:11311

core service [/rosout] found process[rtm_naming-1]: started with pid [22096] process[hrpsys_kill_all-2]: started with pid [22098] /home/sam/prog/rtm-ros-robotics/rtm-ros-robotics/rtmros_common/openrtm/scripts/rtm-naming-restart: line 53: 21875 Killed $cosnames -start $port -logdir $currdir openhrp-aist-dynamics-simulator: no process found openhrp-collision-detector: no process found openhrp-model-loader: no process found openhrp-controller-bridge: no process found openhrp-path-planner: no process found (Not all processes could be identified, non-owned process info will not be shown, you would have to be root to see it all.) [hrpsys_kill_all-2] process has finished cleanly. log file: /home/sam/.ros/log/2faa415a-a6ec-11e1-a8e5-406186e58fd3/hrpsys_kill_all-2*.log

Fri May 25 22:37:53 2012:

Starting omniNames for the first time. Wrote initial log file. Read log file successfully. Root context is IOR:010000002b00000049444c3a6f6d672e6f72672f436f734e616d696e672f4e616d696e67436f6e746578744578743a312e300000010000000000000070000000010102000d0000003139322e3136382e302e31320000f90a0b0000004e616d6553657276696365000300000000000000080000000100000000545441010000001c000000010000000100010001000000010001050901010001000000090101000354544108000000215ec04f01005665 Checkpointing Phase 1: Prepare. Checkpointing Phase 2: Commit. Checkpointing completed. process[grxui-3]: started with pid [22119]

Fri May 25 22:52:53 2012:

Checkpointing Phase 1: Prepare. Checkpointing Phase 2: Commit. Checkpointing completed. ALSO, there are 2 archives at <openhrp3&gt; build="" that="" i="" am="" not="" installing="" since="" the="" instructions="" don't="" say="" to="" install="" them.="" the="" 2="" archives="" are:="" rtmtools100release_en.zip="" and="" j3d-1_5_2-linux-amd64.zip="" (="" i="" have="" a="" 64="" bit="" linux="" )="" should="" i="" install="" those="" two="" archives?<="" p="">

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by 130s
close date 2013-06-07 06:37:35

2 Answers

Sort by » oldest newest most voted
2

answered 2012-05-29 20:06:14 -0500

TurtleBot_Fan gravatar image

Solution for: simulation of Falling Boxes not rendering

The debugging process:

1- Ensured that manual installation of eclipse software was done

1.1 see http://code.google.com/p/rtm-ros-robotics/wiki/ROS_English#Setup_Eclipse

1.2 Also check trouble shooting list. See http://code.google.com/p/rtm-ros-robotics /wiki/ROS_English#Troubleshooting

1.3 When installing GEF SDK 3.6.2 these errors ok sam@Mecha:~/prog/rtm-ros-robotics/rtm-ros-robotics/rtmros_common/openhrp3$ rosrun openhrp3 eclipse.sh I: Injected update sites

   * (Eclipse:3261): CRITICAL *: murrine_style_draw_box: assertion `height >= -1' 
   failed
   * (Eclipse:3261): CRITICAL *: murrine_style_draw_box: assertion `height >= -1'
   failed
   * (Eclipse:3261): CRITICAL *: murrine_style_draw_box: assertion `height >= -1'
   failed
   * (Eclipse:3261): CRITICAL *: murrine_style_draw_box: assertion `height >= -1'
   failed
   * (Eclipse:3261): CRITICAL *: murrine_style_draw_box: assertion `height >= -1' 
   failed
   * (Eclipse:3261): CRITICAL *: murrine_style_draw_box: assertion `height >= -1'
   failed

1.4 Did the following command sam@Mecha:~$ roscd rtmros_common; svn up

  U hrpsys/launch/hrp4c.launch U hrpsys/Makefile.hrpsys-base Conflict discovered 
  in 'hrpsys/index.rst'. Select: (p) postpone, (df) diff-full, (e) edit, (mc)  
  mine-conflict, (tc) theirs-conflict, (s) show all options: 
  (Select the tc option.)

2- Ran sam@Mecha:~$ glxgears

Error: couldn't get an RGB, Double-buffered visual If you meant to select a
glxgears project .xml file, I didn't see one available (now we know something is wrong with the display driver)

3- Used System->Preferences->Screensaver->GLMatrix to verify that GLMatrix would not render

4- Ran: sudo apt-get install --reinstall l freeglut3-dev build-essential libx11-dev libxmu-dev libxi-dev libgl1-mesa-glx libglu1-mesa libglu1-mesa-dev (to ensure the mesa software was installed properly)

Ran: sam@Mecha:~$ glxgears

Error: couldn't get an RGB, Double-buffered visual

Also ran: sam@Mecha:~$ glxinfo | grep '^direct rendering:'

Error: couldn't find RGB GLX visual or fbconfig

(problem is not mesa software)

5- Ran: export LIBGL_ALWAYS_INDIRECT=1

then glxgears WORKS! but the simulation still does not work and GLMatrix screensaver still doesn't work. Newer versions of the GLX library favor direct software rendering over accelerated indirect rendering

6- To see who the libGL files I ran:

sam@Mecha:~$ ls -al /usr/lib/libGL*

-rw-r--r-- 1 root root 487480 2010-01-17 00:07 /usr/lib/libGLEW.a

lrwxrwxrwx 1 root root 16 2012-05-23 17:03 /usr/lib/libGLEW.so ->libGLEW.so.1.5.2

lrwxrwxrwx 1 root root 16 2012-05-23 17:03 /usr/lib/libGLEW.so.1.5 ->libGLEW.so.1.5.2

-rw-r--r-- 1 root root 358456 2010-01-17 00:07 /usr/lib/libGLEW.so.1.5.2

-rw-r--r-- 1 root root 654 2011-07-29 03:02 /usr/lib/libGL.la

lrwxrwxrwx 1 root root 13 2012-05-26 10:23 /usr/lib/libGL.so -> mesa/libGL.so

lrwxrwxrwx 1 root root 15 2011-07-29 03:02 /usr/lib/libGL.so.1 ->libGL.so.275.21

-rwxr-xr-x 1 root root 1023120 2011-07-29 03:02 /usr/lib/libGL.so.275.21

-rw-r--r-- 1 root root 929838 2010-04-28 23:54 /usr/lib/libGLU.a

lrwxrwxrwx 1 root root 11 2012-05-26 10:23 /usr/lib/libGLU.so -> libGLU.so.1

lrwxrwxrwx 1 root root 20 2012-05-26 01:55 /usr/lib/libGLU.so.1 ->libGLU.so.1.3.070701

-rw-r--r-- 1 ... (more)

edit flag offensive delete link more
1

answered 2012-05-25 19:21:55 -0500

Kei Okada gravatar image

You have to manually install software to the eclipse, see http://code.google.com/p/rtm-ros-robotics/wiki/ROS_English#Setup_Eclipse Also check trouble shooting list. See http://code.google.com/p/rtm-ros-robotics/wiki/ROS_English#Troubleshooting

edit flag offensive delete link more

Comments

I already did manual install of software to Eclipse, but I followed the troubleshooting and did it again. When I did the first install of GEF SDK 3.6.2 i got these errors. iare these errors ok? sam@Mecha:~/prog/rtm-ros-robotics/rtm-ros-robotics/rtmros_common/openhrp3$ rosrun openhrp3 eclipse.sh I: Injected update sites

* (Eclipse:3261): CRITICAL *: murrine_style_draw_box: assertion `height >= -1' failed

* (Eclipse:3261): CRITICAL *: murrine_style_draw_box: assertion `height >= -1' failed

* (Eclipse:3261): CRITICAL *: murrine_style_draw_box: assertion `height >= -1' failed

* (Eclipse:3261): CRITICAL *: murrine_style_draw_box: assertion `height >= -1' failed

* (Eclipse:3261): CRITICAL *: murrine_style_draw_box: assertion `height >= -1' failed

* (Eclipse:3261): CRITICAL *: murrine_style_draw_box: assertion `height >= -1' failed

TurtleBot_Fan gravatar imageTurtleBot_Fan ( 2012-05-25 19:37:43 -0500 )edit

For a falling box example, java3declipse-20090302.zip and grxui_eclipse.zip are important. since you have trouble on opengl library, i suppose you'd better to reinstall the these eclipse plugins.

Kei Okada gravatar imageKei Okada ( 2012-05-25 19:50:09 -0500 )edit

be sure that you have opengl properly installed by running glxgears and check if you can see "gears".

Kei Okada gravatar imageKei Okada ( 2012-05-25 19:55:15 -0500 )edit

To reinstall the eclipse plugins, roscd openhrp3; make wipe; then run eclipse and remove insalled plugin (you can remove installed plugin from Help > Install New Software > already installed), roscd openhrp3; make; then install plugins again.

Kei Okada gravatar imageKei Okada ( 2012-05-25 19:58:49 -0500 )edit

I redid all manual install with same bad result. I then did the following, but do not know how to continue with presented choices ?!: sam@Mecha:~$ roscd rtmros_common; svn up U hrpsys/launch/hrp4c.launch U hrpsys/Makefile.hrpsys-base Conflict discovered in 'hrpsys/index.rst'. Select: (p) postpone, (df) diff-full, (e) edit, (mc) mine-conflict, (tc) theirs-conflict, (s) show all options: What should I do? I did: sam@Mecha:~$ glxgears Error: couldn't get an RGB, Double-buffered visual If you meant to select a glxgears project .xml file, I didn't see one available.

TurtleBot_Fan gravatar imageTurtleBot_Fan ( 2012-05-25 20:03:16 -0500 )edit

select tc, sorry for inconvenience. we know this is the problem, but not fixed yet.

Kei Okada gravatar imageKei Okada ( 2012-05-25 20:07:13 -0500 )edit

It's ok about inconvenience. I selected tc and then did: rosmake hrpsys hrpsys_ros_bridge and it completed without errors. I did all the troubleshooting, and seemed ok except I could never get any simulation graphics in 3d tab. I do not know what else to do. Everything seems to be working except for the 3D part of the simulation of falling boxes. One interesting side-effect from installing rtm-ros-robotics is my Matrix screensaver stopped rendering(!)

TurtleBot_Fan gravatar imageTurtleBot_Fan ( 2012-05-25 21:04:26 -0500 )edit

be sure that you have opengl properly installed by running glxgears and check if you can see "gears". If not you still have opengl problems. apt-get install --reinstall libgl1-mesa-dev libgl1-mesa-glx libglu1-mesa-dev

Kei Okada gravatar imageKei Okada ( 2012-05-25 21:49:35 -0500 )edit

Question Tools

2 followers

Stats

Asked: 2012-05-25 18:45:28 -0500

Seen: 393 times

Last updated: May 29 '12