Ask Your Question
0

Command 'roswtf' not found,installation failed.

asked 2020-04-06 21:57:10 -0500

Dean gravatar image

updated 2020-04-07 02:17:15 -0500

gvdhoorn gravatar image

How to solve it?

$ roswtf
Command 'roswtf' not found, but can be installed with:
sudo apt install python-roswtf

$ sudo apt install python-roswtf
[sudo] dean 的密码: 
正在读取软件包列表... 完成
正在分析软件包的依赖关系树       
正在读取状态信息... 完成       
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
 python-roswtf : 依赖: python-rosservice 但是它将不会被安装
                 依赖: python-rosmsg 但是它将不会被安装
                 依赖: python-roslaunch 但是它将不会被安装
                 依赖: python-rosnode 但是它将不会被安装
                 依赖: python-roslib 但是它将不会被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关
edit retag flag offensive close merge delete

Comments

For future questions: please refrain from posting questions in languages other than English.

In this case, the main question was in English, so that's OK. But if error messages or other information is not in English, it'll make it very difficult for others to help you.

gvdhoorn gravatar image gvdhoorn  ( 2020-04-07 02:18:15 -0500 )edit

Ok! From now, I will do everything only in English. Thanks.

Dean gravatar image Dean  ( 2020-04-07 18:52:36 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2020-04-07 00:22:05 -0500

hashirzahir gravatar image

Hi. python-roswtf is the wrong package. Please uninstall it using sudo apt purge python-roswtf. This is the correct package to install:

sudo apt install ros-melodic-roswtf

As a side note, if you want to install any ros packages via apt, you can just search the ros wiki for a package (in this case, roswtf) and typically how you would install it is with the package name ros-DISTRIBUTION-PACKAGENAME. In the case of roswtf, the package name on the ros wiki is roswtf, and I assume you are using ros-melodic, so you can install it using the package name ros-melodic-roswtf. If the package you are installing has an underscore in it, for example move_base, the package name to install via apt becomes ros-melodic-move-base where the underscore in move_base has been replaced with a hyphen (move-base). This naming convention generally true for most packages on the ros wiki (but maybe not all packages).

Hope that helps.

edit flag offensive delete link more

Comments

Yes,it helps,now,it works correctly. You are so great for your side note. I believe it will help me more in the future and more people. Thank you so much!

Dean gravatar image Dean  ( 2020-04-07 02:10:22 -0500 )edit

python-roswtf is the wrong package

Indeed. And see wiki/UpstreamPackages for more information.

gvdhoorn gravatar image gvdhoorn  ( 2020-04-07 02:18:56 -0500 )edit

You are welcome. Glad I could help!

hashirzahir gravatar image hashirzahir  ( 2020-04-13 06:29:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-04-06 21:57:10 -0500

Seen: 111 times

Last updated: Apr 07 '20