Ask Your Question
0

Can someone explain this `catkin_make` error trace?

asked 2020-04-03 13:32:59 -0500

ltbd78 gravatar image
 -- Using these message generators: gencpp;geneus;genlisp;gennodejs;genpy
-- openai_ros: 1 messages, 0 services
CMake Warning at /opt/ros/melodic/share/catkin/cmake/catkin_package.cmake:166 (message):
  catkin_package() DEPENDS on 'gazebo_msgs' but neither
  'gazebo_msgs_INCLUDE_DIRS' nor 'gazebo_msgs_LIBRARIES' is defined.
Call Stack (most recent call first):
  /opt/ros/melodic/share/catkin/cmake/catkin_package.cmake:102 (_catkin_package)
  openai_ros/openai_ros/CMakeLists.txt:104 (catkin_package)


CMake Warning at /opt/ros/melodic/share/catkin/cmake/catkin_package.cmake:166 (message):
  catkin_package() DEPENDS on 'geometry_msgs' but neither
  'geometry_msgs_INCLUDE_DIRS' nor 'geometry_msgs_LIBRARIES' is defined.
Call Stack (most recent call first):
  /opt/ros/melodic/share/catkin/cmake/catkin_package.cmake:102 (_catkin_package)
  openai_ros/openai_ros/CMakeLists.txt:104 (catkin_package)


CMake Warning at /opt/ros/melodic/share/catkin/cmake/catkin_package.cmake:166 (message):
  catkin_package() DEPENDS on 'controller_manager_msgs' but neither
  'controller_manager_msgs_INCLUDE_DIRS' nor
  'controller_manager_msgs_LIBRARIES' is defined.
Call Stack (most recent call first):
  /opt/ros/melodic/share/catkin/cmake/catkin_package.cmake:102 (_catkin_package)
  openai_ros/openai_ros/CMakeLists.txt:104 (catkin_package)


-- +++ processing catkin package: 'follow_line_tc_pkg'
-- ==> add_subdirectory(turtlebot/follow_line_tc_pkg)
-- Could NOT find pid (missing: pid_DIR)
-- Could not find the required component 'pid'. The following CMake error indicates that you either need to install the package with the same name or change your environment so that it can be found.
CMake Error at /opt/ros/melodic/share/catkin/cmake/catkinConfig.cmake:83 (find_package):
  Could not find a package configuration file provided by "pid" with any of
  the following names:

    pidConfig.cmake
    pid-config.cmake

  Add the installation prefix of "pid" to CMAKE_PREFIX_PATH or set "pid_DIR"
  to a directory containing one of the above files.  If "pid" provides a
  separate development package or SDK, be sure it has been installed.
Call Stack (most recent call first):
  turtlebot/follow_line_tc_pkg/CMakeLists.txt:10 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/linsu/simulation_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/linsu/simulation_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-04-04 04:32:45 -0500

The error says Could not find a package configuration file provided by "pid". It looks like the pid package is not installed in your environment. You can automatically download al such dependencies with the rosdep command as described on the rosdep wiki. To fix your problem, go to the root folder of your workspace (one below src) and enter

$ rosdep install --from-paths src --ignore-src -r -y.

Alternatively you could also manually install the package with

$ sudo apt install ros-melodic-pid.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-04-03 13:32:59 -0500

Seen: 334 times

Last updated: Apr 04 '20