Ask Your Question
1

[autoware.auto] How to run the 3D perception stack in ADE?

asked 2020-03-16 15:50:06 -0500

updated 2020-03-16 15:58:00 -0500

I am trying to run the perception stack in Autoware.Auto by going through this documentation:

https://autowarefoundation.gitlab.io/...

However, I am running into problems. The docs say to set the LD_LIBRARY_PATH for nvidia cards as follows:

ade$ export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/usr/local/nvidia/lib64/

But I don't have the /usr/local/nvidia directory in ADE. Then, when I try to run the following command:

ade$ ros2 run velodyne_node velodyne_cloud_node_exe __params:=/home/"${USER}"/AutowareAuto/src/drivers/velodyne_node/param/vlp16_test.param.yaml

I get the following error:

ade$ expected [string] got [not set]

Can anyone help me get the stack up and running?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-03-19 03:57:51 -0500

Andreas Lebherz gravatar image

Hi Jeffrey,

I discovered the same as you two days ago because I had this setup working in the past but had to set it up again on a different machine. I think I found at least a temporal solution to the problem:

I think the git commit "f569ee9a924a757286e6017dd68bd4ec581d5e51" broke(fixed?) something in the velodyne functionality which seems to cause troubles in the handling of the YAML file. My solution for now is to

checkout the previous commit "f8c2ffbaa6223351ea5fa778e8b5e6127c5fa716"

git checkout f8c2ffbaa6223351ea5fa778e8b5e6127c5fa716

$ade colcon build --packages-select

$ade velodyne_driver velodyne_node source

$ade install/setup.bash

$ade ros2 run velodyne_node velodyne_cloud_node_exe __params:=/home/"${USER}"/AutowareAuto/src/drivers/velodyne_node/param/vlp16_test.param.yaml

And this works for me. Maybe I try to investigate what causes the problem and write a ticket to contribute.

Best regards, Andreas

edit flag offensive delete link more

Comments

1

Thanks, that was helpful. There seems to be a mismatch in the node namespace. I've submitted a ticket and attached a merge request with a proposed fix: https://gitlab.com/autowarefoundation...

Jeffrey Kane Johnson gravatar image Jeffrey Kane Johnson  ( 2020-03-19 07:17:56 -0500 )edit

Thanks for sending out the ticket!

( Line 2 and 3 should be a single line ) $ade colcon build --packages-select velodyne_driver velodyne_node source

Andreas Lebherz gravatar image Andreas Lebherz  ( 2020-03-19 10:12:41 -0500 )edit

Okay, I think we figured out a simple way to fix this: just add __ns:=/lidar_frontto the velodyne node launch command. I put in a merge request to update the documentation: https://gitlab.com/autowarefoundation... Thanks for your help, Andreas!

Jeffrey Kane Johnson gravatar image Jeffrey Kane Johnson  ( 2020-03-19 19:41:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2020-03-16 15:50:06 -0500

Seen: 310 times

Last updated: Mar 16 '20