Ask Your Question
0

Connection Timed Out Error during setup keys installation

asked 2012-05-22 19:27:58 -0500

Nishant gravatar image

Hi there! I am new to ROS, and I need a little help here with installing ROS on my Ubuntu. I am running Ubuntu as a virtual OS in Windows 7 using VMware Player. Here are some details regarding the software.

Ubuntu version: Ubuntu 12.04 (Precise) 32-bit

ROS version: ROS fuerte

So I followed the step by step procedure for installing fuerte as given here

http://www.ros.org/wiki/fuerte/Installation/Ubuntu

But when I try to install step number 3 (setup your keys), the connection fails and I get a "Connection timed out. Could not connect to packages.ros.org" error. And then it keeps on trying to connect (which may be because of wget command) but always fails. I am using an Ethernet LAN cable connection for the internet, and the weird part is that I am connected to the net all the while that I am getting this error. I then tried the following, which again is never able to complete (Gets stuck at 0%)

sudo apt-get install update

What may possibly be wrong here? Any kind of help is greatly appreciated!

Thanks!

Nishant.

edit retag flag offensive close merge delete

Comments

I am so sorry for the small mistake in the post above. What I tried out was

sudo apt-get update

This still didn't work though. The computer hangs up on 0%, until I have to kill the process.

Nishant gravatar image Nishant  ( 2012-05-22 23:38:03 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-09 07:38:23 -0500

tfoote gravatar image

updated 2013-05-09 07:39:11 -0500

This sounds like a network connectivity issue. You should check that you can reach packages.ros.org

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-22 19:27:58 -0500

Seen: 1,019 times

Last updated: May 09 '13