Ask Your Question
0

Could not find the planner configuration 'None' on the param server

asked 2020-02-14 02:05:30 -0600

AHJL001 gravatar image

Hello, I am trying to launch my launch file but I am met with a few error messages. The objective of this launch file is to use RVIZ to display my robot. I was able to bring up the RVIZ GUI but nothing else was showing up. The map display also mentions that there was no map specified. Please help, thank you.

The launch file contents:

<launch>
  <!-- The planning and execution components of MoveIt! configured to run -->
  <!-- using the ROS-Industrial interface. -->

  <!-- Non-standard joint names:
       - Create a file [robot_moveit_config]/config/joint_names.yaml
           controller_joint_names: [joint_1, joint_2, ... joint_N]
       - Update with joint names for your robot (in order expected by rbt controller)
       - and uncomment the following line: -->
  <rosparam command="load" file="$(find myworkcell_moveit_config)/config/joint_names.yaml"/>

  <!-- the "sim" argument controls whether we connect to a Simulated or Real robot -->
  <!--  - if sim=false, a robot_ip argument is required -->
  <arg name="sim" default="true" />
  <arg name="robot_ip" unless="$(arg sim)" />

  <!-- load the robot_description parameter before launching ROS-I nodes -->
  <include file="$(find myworkcell_moveit_config)/launch/planning_context.launch" >
   <arg name="load_robot_description" value="true" />
  </include>

  <!-- run the robot simulator and action interface nodes -->
  <group if="$(arg sim)">
    <include file="$(find industrial_robot_simulator)/launch/robot_interface_simulator.launch" />

    <!-- publish the robot state (tf transforms) -->
    <node name="robot_state_publisher" pkg="robot_state_publisher" type="robot_state_publisher" />
  </group>

  <!-- run the "real robot" interface nodes -->
  <!--   - this typically includes: robot_state, motion_interface, and joint_trajectory_action nodes -->
  <!--   - replace these calls with appropriate robot-specific calls or launch files -->
  <group unless="$(arg sim)">
    <remap from="follow_joint_trajectory" to="joint_trajectory_action"/>
    <include file="$(find ur_modern_driver)/launch/ur_common.launch" >
      <arg name="robot_ip" value="$(arg robot_ip)"/>
      <arg name="min_payload" value="0.0"/>
      <arg name="max_payload" value="5.0"/>
    </include>
  </group>

  <include file="$(find myworkcell_moveit_config)/launch/move_group.launch">
    <arg name="publish_monitored_planning_scene" value="true" />
  </include>

  <include file="$(find myworkcell_moveit_config)/launch/moveit_rviz.launch">
    <!-- <arg name="config" value="true"/> -->
  </include>

</launch>

After running $ roslaunch myworkcell_moveit_config demo.launch

There is an error message which shows:

Planning scene monitors started.
[ INFO] [1581661415.277737577]: Initializing OMPL interface using ROS parameters
[ERROR] [1581661415.285019096]: Could not find the planner configuration 'None' on the param server

The subsequent messages are:

[ INFO] [1581661415.328146408]: Using planning interface 'OMPL'
[ INFO] [1581661415.345241373]: Param 'default_workspace_bounds' was not set. Using default value: 10
[ INFO] [1581661415.345810377]: Param 'start_state_max_bounds_error' was set to 0.1
[ INFO] [1581661415.346276251]: Param 'start_state_max_dt' was not set. Using default value: 0.5
[ INFO] [1581661415.346782261]: Param 'start_state_max_dt' was not set. Using default value: 0.5
[ INFO] [1581661415.347236837]: Param 'jiggle_fraction' was set to 0.05
[ INFO] [1581661415.347696292]: Param 'max_sampling_attempts' was not set. Using default value: 100
[ INFO] [1581661415.347767134]: Using planning request adapter 'Add Time Parameterization'
[ INFO] [1581661415.347794595]: Using planning request adapter 'Fix Workspace Bounds'
[ INFO] [1581661415.347822067]: Using planning request adapter 'Fix Start State Bounds'
[ INFO] [1581661415.347845393]: Using ...
(more)
edit retag flag offensive close merge delete

Comments

Just a comment:

<include file="$(find ur_modern_driver)/launch/ur_common.launch" >

Do you have a CB3 controller or newer? Please note the deprecation of ur_modern_driver in that case: Deprecation of ur_modern_driver.

gvdhoorn gravatar imagegvdhoorn ( 2020-02-14 03:04:57 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2020-02-14 11:26:55 -0600

Abhishekpg gravatar image

This is due to the default planner is set to NONE in moveit package. You can change this by editing the ompl config file in the moveit_package/config folder. In that set default planner any available planner in that config file. Eg: RRTConfigDefault

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2020-02-14 02:05:30 -0600

Seen: 13 times

Last updated: 2 days ago