RViz problem: Segmentation faul (core dumped)

asked 2020-02-10 04:35:00 -0600

fendrbud gravatar image

I try to run RViz with rosrun rviz rviz on my Xubuntu 16.04 Xenial OS. I get the following error:

[ INFO] [1581330349.696411821]: rviz version 1.12.17
[INFO] [1581330349.696616387]: compiled against Qt version 5.5.1
[ INFO] [1581330349.696777860]: compiled against OGRE version 1.9.0 (Ghadamon)
Segmentation fault (core dumped)

I have tried to upgrade MESA (http://ubuntuhandbook.org/index.php/2...), as well as solutions proposed in this Q&A post with no luck.

Any suggestions on how to fix this problem?

edit retag flag offensive close merge delete

Comments

Have you tried what the rviz troubleshooting wiki page suggests ? Also what is the output of glxinfo | grep "OpenGL version" ?

Delb gravatar image Delb  ( 2020-02-10 05:33:43 -0600 )edit

I solved my problem. I was trying to run the ROS network on my robot, while monitoring it with RViz from a remote computer. I found this guide on how to connect RViz to a remote ROS Master which solved the issue.

fendrbud gravatar image fendrbud  ( 2020-02-11 02:10:56 -0600 )edit

Glad you solved your issue but I'm surprised that changing the master resolved a segfault issue. If you didn't have the same master between your robot and computer, rviz shouldn't have failed to open but would not have shown anything since there wouldn't have been any topics available (on the master running on your computer).

Delb gravatar image Delb  ( 2020-02-11 04:36:24 -0600 )edit