ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ROS cannot be compiled, tested on RPI 3 and 4

asked 2020-01-25 14:15:17 -0500

phil123456 gravatar image


I installed the latest version of raspbian on both RPI 3 and 4 and it just does not compile

/home/pi/ros_catkin_ws/src/rospack/include/rospack/rospack.h:108:10: fatal error: boost/tr1/unordered_set.hpp: No such file or directory

I first read it was becos RPI4 was too new, but apparently something is broken

I followed this tutorial :

I use : 2019-09-26-raspbian-buster.img

how can I fix this ?


edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2020-01-25 15:35:47 -0500

marguedas gravatar image

There is currently no version of ROS targeting Debian Buster. It looks like you're trying to install a version of ROS targeting an older version of boost (<1.63) than the one available on your system (Buster 1.67). In your version these headers don't exist anymore.

The header names have been updated in later versions of ROS

You could to try to compile ROS Melodic rather than ROS Kinetic that targets more recent OSes. You should be able to follow the same instructions and just replace kinetic with melodic in the commands.

edit flag offensive delete link more


jolly good, I'll give it a try, I am a complete noob, so... thanks

phil123456 gravatar image phil123456  ( 2020-01-25 16:41:06 -0500 )edit

ok so it works, it crashed on compilation but I just reran it with the -j2 option

phil123456 gravatar image phil123456  ( 2020-01-26 03:36:14 -0500 )edit

Glad it worked for you,

You can mark the answer as accepted by clicking the checkmark, this will let the community know that this has been solved and doesn't need additional invstigation

marguedas gravatar image marguedas  ( 2020-01-26 04:35:19 -0500 )edit

Question Tools


Asked: 2020-01-25 14:14:13 -0500

Seen: 112 times

Last updated: Jan 26 '20