Ask Your Question
1

"No devices connected..." error with Turtlebot

asked 2012-05-17 08:57:19 -0500

TaylorC gravatar image

I am getting a no devices connected error when attempting to launch the kinect. I have turtlebot dashboard up and running in full mode with 0 breaker green. My Kinect is plugged in as well and it looks like the other components are coming on except for the camera. I have also tried "roslaunch openni_camera openni_node.launch".

turtlebot@turtlebot:~$ roslaunch turtlebot_bringup kinect.launch ... logging to /home/turtlebot/.ros/log/30c60d6e-a050-11e1-9212-9cb70d1ffd03/roslaunch-turtlebot-5253.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://10.5.6.187:35868/

SUMMARY

PARAMETERS * /kinect_laser/max_height * /openni_camera/depth_rgb_rotation * /rosdistro * /openni_camera/image_mode * /openni_camera/image_time_offset * /openni_camera/projector_depth_baseline * /kinect_laser_narrow/output_frame_id * /openni_camera/depth_mode * /kinect_laser_narrow/max_height * /openni_camera/depth_frame_id * /openni_camera/depth_time_offset * /kinect_laser/output_frame_id * /rosversion * /openni_camera/depth_registration * /openni_camera/debayering * /openni_camera/depth_rgb_translation * /kinect_laser/min_height * /pointcloud_throttle/max_rate * /openni_camera/shift_offset * /kinect_laser_narrow/min_height * /openni_camera/rgb_frame_id

NODES / kinect_breaker_enabler (turtlebot_node/kinect_breaker_enabler.py) openni_manager (nodelet/nodelet) openni_camera (nodelet/nodelet) pointcloud_throttle (nodelet/nodelet) kinect_laser (nodelet/nodelet) kinect_laser_narrow (nodelet/nodelet)

ROS_MASTER_URI=http://10.5.6.187:11311

core service [/rosout] found process[kinect_breaker_enabler-1]: started with pid [5273] process[openni_manager-2]: started with pid [5274] process[openni_camera-3]: started with pid [5275] process[pointcloud_throttle-4]: started with pid [5276] process[kinect_laser-5]: started with pid [5277] process[kinect_laser_narrow-6]: started with pid [5292] [kinect_breaker_enabler-1] process has finished cleanly. log file: /home/turtlebot/.ros/log/30c60d6e-a050-11e1-9212-9cb70d1ffd03/kinect_breaker_enabler-1*.log

edit retag flag offensive close merge delete

Comments

SOLVED - The power cable down in the bot had wiggled loose.

TaylorC gravatar image TaylorC  ( 2012-05-17 09:37:16 -0500 )edit

Please post the solution as an "answer" and then accept it once you are able to (in perhaps a week or so I believe it might let you). This will let others easily see that the question has a solution and find the correct solution. Thanks for helping to keep ROS Answers organized and easy to use!

Eric Perko gravatar image Eric Perko  ( 2012-05-17 11:00:55 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-05-18 03:59:36 -0500

TaylorC gravatar image

The power cable down in the bot had wiggled loose.

Eric - Thanks for notifying me! I am still getting used to the forum.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-17 08:57:19 -0500

Seen: 576 times

Last updated: May 18 '12