Ask Your Question
0

openni_tracker on ubuntu11.10 on VMware

asked 2012-05-16 04:14:48 -0500

nnyJoh gravatar image

updated 2014-01-28 17:12:20 -0500

ngrennan gravatar image

Hello. I'm very new to linux and ros. I have installed ubuntu 11.10 on VMware. I have installed ROS following guide from here "http://www.ros.org/wiki/electric/Installation/Ubuntu" and openni_kinect from here "http://www.ros.org/wiki/openni_kinect". Now when I run "roscore" on one terminal (it runs successfully) and "rosrun openni_tracker openni_tracker" on other terminal, nothing is happening (even when I stand in front of sensor). When I run "rosnode list" on third terminal, there is "/openni_tracker" node added to the list. When I run "rostopic list" there is no new topics. After a while of nothingness, an error appears and it stops. The error is: "[ERROR] [1336588766.792536891]: InitFromXml failed: Xiron OS got an event timeout!" The "/openni_tracker" node is gone after that. Each time I try to run it again, I get error almost immediately. Error is: "[ERROR] [1337177233.598450808]: InitFromXml failed: Got a timeout while waiting for a network command to complete!". The "/openni_tracker" node is also created for a short period.

Also if I would try to launch other things, if something wouldn't work, it would be because some sort of timeout error so I guess it's the same problem. Please help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-05-17 11:57:01 -0500

Hansg91 gravatar image

Hi there,

The Kinect device does not seem to work in a VM. The only solution I know is to dual boot Ubuntu.

Best regards.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-16 04:14:48 -0500

Seen: 287 times

Last updated: May 17 '12