Resource not found

asked 2019-12-10 07:04:29 -0600

zahid990170 gravatar image

updated 2019-12-10 10:03:41 -0600

Hi,

I am working within a simple ROS workspace where I have two packages.

I have included in my workspace (as a new package, "robotic_moveit_config") a configuration generated by MoveIt setup assistant. My question is about this particular package. The configuration generated by MoveIt setup assistant already creates different launch files.

I can build the workspace correctly, and then using roslaunch I can successfully run, for example.

roslaunch robotic_moveit_config demo.launch

and so I can test simple planning scenarios in rviz.

At the same time, I am trying to write some simple motion planning programs.

zahid_test_workspace

src  
--  my_test_pkg
--   ur5_moveit_config 

      -- include
      -- src
      -- launch    
         -- smp.launch

Here, when I try to issue

roslaunch ur5_moveit_config smp.launch

I receive the following error. Resource not found: ur_description

Although before running roslaunch, I do the following

source /opt/ros/melodic/setup.bash
source ~/catkin_ws/devel/setup.bash
source devel/setup.bash

The strange thing is that, other day, I was able to launch my program. Here is the launch file that I am using.

<launch>
<include file="$(find ur5_moveit_config)/launch/demo.launch"/>
<node name="ur5" pkg="ur5_moveit_config" type="ur5" respawn="false" output="screen"/>
</launch>

thanks,

Zahid

edit retag flag offensive close merge delete

Comments

Did you build your workspace before calling source devel/setup.bash? Can you please add the output of echo $ROS_PACKAGE_PATH?

ct2034 gravatar imagect2034 ( 2019-12-10 07:54:45 -0600 )edit

I build the package using, catkin clean followed by catkin build then I issued source devel/setup.bash

The complete error is follows

Resource not found: ur_description
ROS path [0]=/opt/ros/melodic/share/ros
ROS path [1]=/home/zahid/Desktop/IMPLEMENTATIONS/zahid_test_ws/src
ROS path [2]=/opt/ros/melodic/share
The traceback for the exception was written to the log file

and the output from echo $ROS_PACKAGE_PATH

/home/zahid/ws_moveit/src/ros-moveit-arm/moveit_plugin:/home/zahid/ws_moveit/src/moveit_tutorials:/home/zahid/ws_moveit/src/ros-moveit-arm/my_arm_xacro:/home/zahid/ws_moveit/src/panda_moveit_config:/opt/ros/melodic/share
zahid990170 gravatar imagezahid990170 ( 2019-12-10 09:18:29 -0600 )edit

I explicitly added the following path

export ROS_PACKAGE_PATH=/home/zahid/catkin_ws/src/universal_robot:$ROS_PACKAGE_PATH

to the ROS_PACKAGE_PATH. Then, to confirm I issue echo $ROS_PACKAGE_PATH and I receive the following output

/home/zahid/catkin_ws/src/universal_robot:/home/zahid/Desktop/IMPLEMENTATIONS/zahid_test_ws/src/my_test_pkg:/home/zahid/Desktop/IMPLEMENTATIONS/zahid_test_ws/src/ur5_moveit_config:/opt/ros/melodic/share

The directory ur_description is found under /home/zahid/catkin_ws/src/universal_robot, and therefore I added this path. Following this, I issue source devel/setup.bash and roslaunch robotic_moveit_config smp.launch and still see the following

Resource not found: ur_description
ROS path [0]=/opt/ros/melodic/share/ros
ROS path [1]=/home/zahid/Desktop/IMPLEMENTATIONS/zahid_test_ws/src/my_test_pkg
ROS path [2]=/home/zahid/Desktop/IMPLEMENTATIONS/zahid_test_ws/src/ur5_moveit_config
ROS path [3]=/opt/ros/melodic/
zahid990170 gravatar imagezahid990170 ( 2019-12-10 09:48:05 -0600 )edit

i tried the following

  1. adding the following line to the ~/.bashrc file.

    export ROS_PACKAGE_PATH=~/catkin_ws/src/universal_robot:${ROS_PACKAGE_PATH}

  2. copying the directory ur_description under /home/zahid/Desktop/IMPLEMENTATIONS/zahid_test_ws/src/ur5_moveit_config/

But, still the same problem persists.

thanks for your time.

zahid990170 gravatar imagezahid990170 ( 2019-12-10 10:51:07 -0600 )edit