Problem with UR5 and ur_robot_driver:

asked 2019-12-10 05:54:40 -0600

sb97 gravatar image

I am trying to control a UR5 with a remote pc in VMware

remote pc:

-Ubuntu 16.04

-ros kinetic

UR5:

URSoftware 3.7.0.40195

I am using the ur_robot_driver to connect to the robot and moveit to plan a trajectory. Once i execute a the in rviz planned trajectory i get this error(Can't accept new action goals. Controller is not running.) . My steps are as follows

1.

roslaunch ur_robot_driver ur5_bringup.launch robot_ip:=192.168.74.128

2.Start URCap Program that was created in this tutorial

3.start moveit

roslaunch ur5_moveit_config ur5_moveit_planning_execution.launch
roslaunch ur5_moveit_config moveit_rviz.launch config:=true

I get the following outputs in the 3 terminals and the rostopic list see below

In Rviz i get the correct pose of the roboter, but if i execute the new pose i get the error mentioned above (new terminal output is also below)

I already changed the controllers.yaml file in the ur5_moveit_config

controller_list:
- name: /pos_traj_controller
action_ns: follow_joint_trajectory
type: FollowJointTrajectory
default: true
joints:
  - shoulder_pan_joint
  - shoulder_lift_joint
  - elbow_joint
  - wrist_1_joint
  - wrist_2_joint
  - wrist_3_joint

I saw on other questions that this could be an issue. With the default name i got this error(Action client not connected: /follow_joint_trajectory). I am quite new to ros and i followed the tutorials to install universal_robot and ur_modern_driver. A few days ago i tried the ur_modern_driver to connect to the robot and i was able to execute the test_move.py . However this driver isnt working anymore on my maschine, i guess thats a different issue.

output:

Terminal 1:

steffen@ubuntu:~/catkin_ws$ roslaunch ur_robot_driver ur5_bringup.launch robot_ip:=192.168.74.128 ... logging to /home/steffen/.ros/log/cebc2656-1b3c-11ea-b56e-000c29fb465b/roslaunch-ubuntu-48110.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://ubuntu:36177/

SUMMARY

PARAMETERS

  • /controller_stopper/consistent_controllers: ['joint_state_con...

    • /force_torque_sensor_controller/publish_rate: 125

    • /force_torque_sensor_controller/type: force_torque_sens...

    • /hardware_control_loop/loop_hz: 125

    • /hardware_interface/joints: ['shoulder_pan_jo...

    • /joint_state_controller/publish_rate: 125

    • /joint_state_controller/type: joint_state_contr...

    • /pos_traj_controller/action_monitor_rate: 10

    • /pos_traj_controller/constraints/elbow_joint/goal: 0.1

    • /pos_traj_controller/constraints/elbow_joint/trajectory: 0.2

    • /pos_traj_controller/constraints/goal_time: 0.6

    • /pos_traj_controller/constraints/shoulder_lift_joint/goal: 0.1

    • /pos_traj_controller/constraints/shoulder_lift_joint/trajectory: 0.2

    • /pos_traj_controller/constraints/shoulder_pan_joint/goal: 0.1

    • /pos_traj_controller/constraints/shoulder_pan_joint/trajectory: 0.2

    • /pos_traj_controller/constraints/stopped_velocity_tolerance: 0.05

    • /pos_traj_controller/constraints/wrist_1_joint/goal: 0.1

    • /pos_traj_controller/constraints/wrist_1_joint/trajectory: 0.2

    • /pos_traj_controller/constraints/wrist_2_joint/goal: 0.1

    • /pos_traj_controller/constraints/wrist_2_joint/trajectory: 0.2

    • /pos_traj_controller/constraints/wrist_3_joint/goal: 0.1

    • /pos_traj_controller/constraints/wrist_3_joint/trajectory: 0.2

    • /pos_traj_controller/joints: ['shoulder_pan_jo...

    • /pos_traj_controller/state_publish_rate: 125

    • /pos_traj_controller/stop_trajectory_duration: 0.5

    • /pos_traj_controller/type: position_controll...

    • /robot_description:

    • /rosdistro: kinetic

    • /rosversion: 1.12.14

    • /scaled_pos_traj_controller/action_monitor_rate: 10

    • /scaled_pos_traj_controller/constraints/elbow_joint/goal: 0.1

    • /scaled_pos_traj_controller/constraints/elbow_joint/trajectory: 0.2

    • /scaled_pos_traj_controller/constraints/goal_time: 0.6

    • /scaled_pos_traj_controller/constraints/shoulder_lift_joint/goal: 0.1

    • /scaled_pos_traj_controller/constraints/shoulder_lift_joint/trajectory: 0.2

    • /scaled_pos_traj_controller/constraints/shoulder_pan_joint/goal: 0.1

    • /scaled_pos_traj_controller/constraints/shoulder_pan_joint/trajectory: 0.2

    • /scaled_pos_traj_controller/constraints/stopped_velocity_tolerance: 0.05

    • /scaled_pos_traj_controller/constraints/wrist_1_joint/goal: 0.1

    • /scaled_pos_traj_controller/constraints/wrist_1_joint/trajectory: 0.2

    • /scaled_pos_traj_controller/constraints/wrist_2_joint/goal: 0.1

    • /scaled_pos_traj_controller/constraints ...

(more)
edit retag flag offensive close merge delete

Comments

Can you tell us how you've configured networking in your VM?

If you're using NAT, you'll have to open up the "return port" in the NAT configuration, otherwise the program running on the UR controller will not be able to connect back to the driver node.

Finally: you may want to post your question to the ur_robot_driver issue tracker.

gvdhoorn gravatar imagegvdhoorn ( 2019-12-10 05:57:19 -0600 )edit

Yes i am using NAT . The remote ubuntu pc and the URSim UR5 are running both on seperate VMs with a static IP. Would this mean i have to use the roslaunch ur_robot_driver ur5_bringup.launch robot_ip:=IP_OF_THE_ROBOT [reverse_port:=REVERSE_PORT] with the port specified in the URCap program or do i have to put the IP and the Port into the NAT Setting of VMware. As mentioned im quite new to this topic and unfortunatly im not able to upload screens of my settings. I tested the same procedure on a maschine of a friend which runs ubuntu 16.04 and ros kinetic natively und URSim directly on that maschine. There the same error occurs.

sb97 gravatar imagesb97 ( 2019-12-10 06:50:12 -0600 )edit