Ask Your Question
0

Depth Image after rectified has noise

asked 2019-12-03 04:51:26 -0600

lfrobotics gravatar image

updated 2019-12-03 09:22:45 -0600

Hi, I'm running ROS Melodic on Ubuntu 18.04 and using a Kinect DK.

When I run the Azure Kinect DK ROS's launch file here:

https://github.com/microsoft/Azure_Ki...

The depth image point cloud after rectification looks very weird, like there is a lot of random points of noise near the source image. I have attached an image of what it looks like. I figure that image_proc/rectify nodelet may be causing some performance issues, but I'm not sure how to tackle this problem. Would appreciate any help. I have attached some images of what happens.

As I have less than 5 points, I have uploaded the pictures on to a google drive. As you can see, the rectified image has a lot of noise that affects my calculations. Thanks in advance for any help!

Before recitification, the photo seems perfectly normal. b As you can see, the picture below is heavily scattered with random noise. image description

edit retag flag offensive close merge delete

Comments

1

As I have less than 5 points

Not any more, so please attach your images directly to the question.

gvdhoorn gravatar imagegvdhoorn ( 2019-12-03 06:22:03 -0600 )edit

Thanks, done!

lfrobotics gravatar imagelfrobotics ( 2019-12-03 20:23:25 -0600 )edit

Could be that the calibration is poor or a bug in the rectification process. How did you calibrate the camera? May be faster to attempt recalibration to see if it helps / hurts. Quickest solution I could mention is to use an edge filter to kill those points

stevemacenski gravatar imagestevemacenski ( 2019-12-04 11:30:30 -0600 )edit

Hi Steve, thanks for your answer. I checked in with the Kinect ROS package maintainer and they did mention it was an image_proc bug, "image_proc/rectify seems to be using interpolation=1 (linear interpolation) when it should be using interpolation=0 (nearest neighbor)." I fixed this and then it solved the problem. I will attach the relevant github issue for those who might have this issue.

lfrobotics gravatar imagelfrobotics ( 2019-12-04 21:08:35 -0600 )edit

Sounds good. You should file that on image pipeline (where I’m a maintainer) & submit your fix in a PR. I’ll merge that.

stevemacenski gravatar imagestevemacenski ( 2019-12-04 21:27:08 -0600 )edit

Ah I see its just a remap parameter. Seems like you’re good to go!

stevemacenski gravatar imagestevemacenski ( 2019-12-04 21:27:45 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-12-04 21:08:58 -0600

lfrobotics gravatar image

This issue has been solved here: https://github.com/microsoft/Azure_Ki...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-12-03 04:48:40 -0600

Seen: 24 times

Last updated: Dec 04