Ask Your Question
1

Failing to start autoware auto on NVidia Jetson Xavier

asked 2019-12-02 17:35:15 -0500

blarghflargle gravatar image

I followed the installation instructions for Autoware.auto found in this link: https://autowarefoundation.gitlab.io/... but I am encountering an error when I run ade start. My terminal shows

nvidia@matt-xavier:~/m2/adehome/AutowareAuto$ ade start
Starting ade with the following images:
ade          | n/a     | master | registry.gitlab.com/autowarefoundation/autoware.auto/autowareauto/ade:master
ade-atom     | v1.39.1 | latest | registry.gitlab.com/apexai/ade-atom:latest                                  
autowareauto | n/a     | master | registry.gitlab.com/autowarefoundation/autoware.auto/autowareauto:master    
ade_registry.gitlab.com_apexai_ade-atom_latest
ade_registry.gitlab.com_autowarefoundation_autoware.auto_autowareauto_master
non-network local connections being added to access control list
standard_init_linux.go:211: exec user process caused "exec format error"
ERROR: Failed to start ade. Re-run with --debug to get more information.

Of course when I run ade --debug, I get Error: no such option: --debug. How do I resolve this problem?

I am using a NVidia Jetson AGX Xavier flashed with JetPack 4.2.2 (so Ubuntu 18.04 bionic). I did not explicitly install any version of ROS 2, since I assumed that was part of the docker image in ADE (and no part of the installation instructions told me to explicitly install ROS 2). I have ROS melodic installed, if that's relevant.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2019-12-03 03:18:17 -0500

sgermanserrano gravatar image

@blarghflargle that looks like a compatibility issue with the ade image, since your board is Arm based and looks like the ade image is compiled for amd64 architectures. You can try building it natively

edit flag offensive delete link more

Comments

Thank you for your response! How did you find that the ade image is compiled for amd64? And how do I build it natively?

blarghflargle gravatar image blarghflargle  ( 2019-12-03 12:36:02 -0500 )edit

This is correct. The Docker containers for ade are currently not compiled natively for arm64, only for amd64 which means they can not be run on an ARM-based processor like the Jetson.

Josh Whitley gravatar image Josh Whitley  ( 2019-12-03 13:00:59 -0500 )edit

@sgermanserrano@Maximus5684 How would I go about building the docker image for ARMv8?

blarghflargle gravatar image blarghflargle  ( 2019-12-03 13:13:44 -0500 )edit

@blarghflargle you'll need to put together a Dockerfile based on ROS Dashing and Melodic, since .auto depends on the ros1_bridge, clone the .auto repo and colcon build it. Or, you can pull this .auto docker image I put together to use in 96Boards hardware which is also arm64 based

sgermanserrano gravatar image sgermanserrano  ( 2019-12-04 02:55:17 -0500 )edit

thanks @sgermanserrano ! How do I actually make use of the .auto docker image you put together? do I put registry.hub.docker.com/96boards/autoware:auto in the .aderc?

blarghflargle gravatar image blarghflargle  ( 2019-12-06 16:55:20 -0500 )edit

@blarghflargle you should be able to follow the steps here for your hardware

sgermanserrano gravatar image sgermanserrano  ( 2019-12-09 09:38:51 -0500 )edit
0

answered 2019-12-03 22:34:05 -0500

ruffsl gravatar image

updated 2019-12-03 22:34:27 -0500

This is a bit dated, but you can look at this post for links on how to change/build image architectures on a foreign host:

https://discourse.ros.org/t/announcin...

Check the "Supported architectures" section on the official docker library for available architectures:

https://hub.docker.com/_/ros

edit flag offensive delete link more
0

answered 2020-04-02 21:39:28 -0500

Josh Whitley gravatar image

I know this post is a little old but I wanted to provide an update that arm64-native ADE images are now available! On Jetson Xavier (or other native arm64 platforms), all you should have to do to test them is source the .aderc-arm64 file in the root of the AutowareAuto repo before running ade start.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-12-02 17:35:15 -0500

Seen: 313 times

Last updated: Apr 02