Can't read custom message after updating Matlab

asked 2019-11-17 17:16:46 -0600

not_pROS gravatar image

Recently updated Matlab from 2019a to 2019b. Had to remove 2019a before updating due to limited disk space.

I'm currently working on something that involves messages of the type "vicon_tools/ros_object_array ", which I had to create a custom message for using "ROS Toolbox Interface for ROS Custom Messages" and the "rosgenmsg" function. This worked flawlessly in 19a. However, after upgrading to 19b, something is not working. When I try to echo the topic in the command window (works fine in terminal) I get the following error message:

Expected msg to be one of these types:

ros.Message

Instead its type was double.

Creating a subscriber to the topic and looking at the subscriber variable shows five properties:

TopicName
MessageType
LatestMessage
BufferSize
NewMessageFcn

, but their value fields are all empty, which they shouldn't be. My colleague, who runs 2019b, doesn't have this issue. I have tried re-installing Matlab but that didn't help.

edit retag flag offensive close merge delete

Comments

1

Hi,

Did you re-create your custom message in R2019b? Or were you reusing it from the R2019a definition stored in the MATLAB preferences?

A.G. gravatar imageA.G. ( 2019-11-18 12:04:34 -0600 )edit

Hi, Thanks for your reply. Initially I think I was reusing the old R2019a definition (not sure where to find that in my preferences though). However at one time I uninstalled R2019b, removed pretty much anything Matlab, and tried to re-install 2019b as well as recreating the the custom message. But I still get the same error message. Maybe I didn't completely remove the old definition?

not_pROS gravatar imagenot_pROS ( 2019-11-21 03:18:54 -0600 )edit