Ask Your Question
0

catkin build gets stuck while building mavros

asked 2019-11-01 00:17:58 -0600

prashantpd gravatar image

I am attempting to install mavros from src following the instructions in https://github.com/mavlink/mavros/blo...

I am working on Debian/buster aarch64 and have ROS Melodic installed from source as well in a separate workspace. When I run the catkin build command to install mavros, the build gets stuck around 9% or 14% and my system stops responding. There is nothing else I can do except reboot. I tried downgrading Mavros to 0.31.0 but the behaviour is the same.

Any hints?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-11-02 08:57:53 -0600

gvdhoorn gravatar image

Have you checked whether your system is running out of memory or is spinning CPU at 100%? Seeing the mention of aarch64 this is an ARM board, probably embedded with limited resources. CMake tries to parallelise builds as much as possible and it may just be overloading your system.

edit flag offensive delete link more

Comments

@gvdhoorn. It was indeed a problem with the memory. Reran the command as catkin build -j1 and the build took longer but it completed. Thanks to a suggestion on gitter

prashantpd gravatar imageprashantpd ( 2019-11-03 22:33:56 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-11-01 00:17:58 -0600

Seen: 19 times

Last updated: Nov 01