Ask Your Question
0

Why the raw data detected by lidar are very small?

asked 2019-10-27 09:16:14 -0600

PhaTracer gravatar image

updated 2019-10-27 09:27:58 -0600

In fact,my lidar data structure just look like this,I can see that the ranges column data is very small and not realistic, as if it were surrounded by a circle.:

seq: 25
stamp:
secs: 78
nsecs: 777000000
frame_id: "hokuyo_link"
angle_min: -1.57079994678
angle_max: 1.57079994678
angle_increment: 0.0175508372486
time_increment: 0.0
scan_time: 0.0
range_min: 0.0
range_max: 10.0
ranges: [0.05088043585419655, 0.032888345420360565, 0.00824850331991911, 0.03751131519675255, 0.037233006209135056, 0.016207106411457062, 0.029215959832072258, 0.02978556416928768, 0.019236300140619278, 0.025845319032669067, 0.008902770467102528, 0.026326626539230347, 0.023051125928759575, 0.03724529221653938, 0.031686700880527496, 0.00010798007133416831, 0.024950098246335983, 0.019893385469913483,  0.044057343155145645, 0.046771299093961716, 0.03137718886137009, 0.024098888039588928, 0.03176361322402954, 0.021393034607172012.......]enter code here

If I am not mistaken, the data in the ranges should represent the corresponding [angle, distance], thus ranging, the data should be like this:

seq: 25
stamp:
secs: 78
nsecs: 777000000
frame_id: "hokuyo_link"
angle_min: -1.57079994678
angle_max: 1.57079994678
angle_increment: 0.0175508372486
time_increment: 0.0
scan_time: 0.0
range_min: 0.0
range_max: 10.0
ranges: [10.0, 10.0, 10.0, 10.0,10.0, 10.0,10.0, 10.0, 10.0, 10.0,10.0, 10.0,10.0, 10.0, 10.0, 10.0,10.0, 10.0, 10.0, 10.0, 10.0, 10.0,10.0, 10.0,8.0, 8.0, 8.0, 8.0,8.0, 8.0,8.0, 8.0,8.0, 8.0,8.0, 8.0, 8.0, 8.0, 8.0, 8.0,8.0, 8.0,8.0, 8.0,8.0, 8.0,8.0, 8.0,.....]

My lidar settings are as follows:
Configured as:
<gazebo reference="hokuyo_link">
    <sensor type="ray" name="head_hokuyo_sensor">
 <pose>0 0 0 0 0 0</pose>
 <visualize>true</visualize>
 <update_rate>60</update_rate>
 <ray>
   <scan>
     <horizontal>
       <samples>180</samples>
       <resolution>1</resolution>
       <min_angle>-1.570796</min_angle>
       <max_angle>1.570796</max_angle>
     </horizontal>
   </scan>
   <range>
     <min>0</min>
     <max>10.0</max>
     <resolution>0.01</resolution>
   </range>
   <noise>
     <type>gaussian</type>
     <mean>0.0</mean>
     <stddev>0.01</stddev>
   </noise>
 </ray>
 <plugin name="gazebo_ros_head_hokuyo_controller" filename="libgazebo_ros_laser.so">
   <topicName>/autonomous_car/laser/scan</topicName>
   <frameName>hokuyo_link</frameName>
 </plugin>
</sensor>
</gazebo>

The data I get here is very small distance data, but the upper limit is 10m, which prevents me from getting distance information from the original data.And I am sorry that I can't upload an image.

How can I modify it to get normal lidar data?Thanks for your help!

edit retag flag offensive close merge delete

Comments

3

Is there something in your simulation model that is occluding the lasers field of view? This could be hitting the mesh of the robot.

stevemacenski gravatar imagestevemacenski ( 2019-10-27 17:19:23 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-10-28 03:21:14 -0600

duck-development gravatar image

I think you gazebo model see some obstacles.

Do you see the beams in the gazebo simulation do this look like expected?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-10-27 09:16:14 -0600

Seen: 22 times

Last updated: Oct 28