ROS for Raspberry Pi 4

asked 2019-10-04 06:11:00 -0600

ManjushaP gravatar image

Hello

I am a beginner trying to use ROS Kinetic on Raspberry Pi 4. The RPi 4 is loaded with the Raspbian Buster OS. I tried installing ROS kinetic using the following link: http://wiki.ros.org/ROSberryPi/Instal...

Despite this, I am unable to run the basic commands like roscore, rosrun, etc. without an error saying that bash: the command is not found in the directory. Also, I have not installed any Ubuntu Mate image on my SD card. Is it a prerequisite?

After uninstalling Kinetic, i tried installing Melodic using the following link: https://www.seeedstudio.com/blog/2019...

I got an Import error during 'sudo rosdep init' saying that the rospkg.os was not found. If possible, could anybody give me detailed guidelines on how to install ROS on RPi4? Would be really appreciated.

Thank you.

edit retag flag offensive close merge delete

Comments

hey have you tried ubuntu ubiquity ?

kallivalli gravatar imagekallivalli ( 2019-10-07 03:29:47 -0600 )edit

I have similar questions. Currently only "An SD Card Image with Ubuntu 16.04 (LXDE) and ROS Kinetic ... for the Raspberry Pi 3"

I wonder if there will be a new SD card image be available for Raspberry Pi 4? Since I am thinking whether I should buy Pi 4 since it has more computational power. But I am concerned that ROS does not run well on Pi 4. Thank you.

sentry5588 gravatar imagesentry5588 ( 2019-12-28 09:39:43 -0600 )edit