Problem with installing ROS on Ubuntu 18.04

asked 2019-09-17 03:38:25 -0600

Robertslipac gravatar image

updated 2019-09-18 16:04:55 -0600

I am trying to install ROS on a Ubuntu 18.04, I have followed the steps from the wiki for installation and cannot complete this following line:

sudo apt install ros-melodic-desktop-full

The error message prints out:

Reading package lists… Finished
Builds dependency trees
Reading state information ... Finished
Some packages could not be installed. It may mean that you have requested
an impossible situation or, if you use the unstable distribution
that some necessary packages have not yet been created or moved
from "Incoming".
The following information may help to resolve the situation:

The following packages have dependencies that cannot be satisfied:
 ros-melodic-desktop-full: Dependent on: ros-melodic-desktop but it will not be installed
                            Depending on: ros-melodic-perception but it will not be installed
                            Depending on: ros-melodic-simulators but it will not be installed
                            Depending on: ros-melodic-urdf-sim-tutorial but it will not be installed
E: Could not correct the problems, you have withheld broken packages.

Does anyone know how I can get past this problem? Thank you in advance.

EDIT:

I have now succesfully installed ROS!!

I used aptitude for ubuntu - Advanced Packaging Tool (APT) system.

Does this mess up something considering path folders? By doing this I have no path called "opt/ros/melodic"... Now I cannot perform any environment setup. Meaning I cannot run the following instructions from ROS:

echo "source /opt/ros/melodic/setup.bash" >> ~/.bashrc source ~/.bashrc

bash: /opt/ros/melodic/setup.bash: No such file or directory

Please help me with this

edit retag flag offensive close merge delete

Comments

have you added keys ad source list ? and sudo updated ??

kallivalli gravatar imagekallivalli ( 2019-09-17 04:28:12 -0600 )edit

Yes ofcorse, the previous steps for the installation was completed, adding keys gave output: OK.

Robertslipac gravatar imageRobertslipac ( 2019-09-17 04:32:23 -0600 )edit

(sudo apt-get install -f) try this and then install

kallivalli gravatar imagekallivalli ( 2019-09-17 04:40:03 -0600 )edit

I Tried this but same error message shows for installing ros

Robertslipac gravatar imageRobertslipac ( 2019-09-17 05:09:35 -0600 )edit

Please take a look at the edited problem to see output of your tip, can you help me further? thank you for your time

Robertslipac gravatar imageRobertslipac ( 2019-09-17 06:23:12 -0600 )edit

have you seen that answer ?

kallivalli gravatar imagekallivalli ( 2019-09-17 06:58:58 -0600 )edit

Yes, I have managed to go through most of the same relative searches on this forum and google a bit. I tried this answer again just in case but still at the same problem...

I get the same problem for all ROS version such as: sudo apt-get install ros-desktop-full sudo apt-get install ros-kinetic-desktop-full

Robertslipac gravatar imageRobertslipac ( 2019-09-17 07:24:44 -0600 )edit