Ask Your Question
0

boost_signals library not found

asked 2019-09-16 12:12:29 -0500

midas gravatar image

updated 2019-09-17 13:50:08 -0500

I am using a Fedora 30 Workstation. I want to install ROS. Tutorial/Instructions link : http://wiki.ros.org/melodic/Installat....

The Step 2.1.2 Building the catkin Workspace, when I execute the given command, It fails. There are 2 errors that I can see from the terminal output

  1. Could not find the following Boost libraries: boost_signals
  2. Failed to process package 'tf2'

For the 1st error, I checked the /usr/share/cmake/Modules/FindBoost.cmake file, It has a single line referring to the signals headers : set(_Boost_SIGNALS_HEADERS "boost/signals2.hpp"). The file signals2.hpp exists in the boost directory, so that is not the issue. ROS, I guess, is not able to find this header file for some reason. I have also installed all the boost libraries via dnf ( boost, boost-devel, boost-python3).

For the 2nd error, I have installed the geometry libraries via dnf, it doesn't solve the issue.

CMake Error at /usr/share/cmake/Modules/FindBoost.cmake:2165 (message):
  Unable to find the requested Boost libraries.
  Boost version: 1.69.0
  Boost include path: /usr/include
  Could not find the following Boost libraries:
        boost_signals
  Some (but not all) of the required Boost libraries were found.  You may
  need to install these additional Boost libraries.  Alternatively, set
  BOOST_LIBRARYDIR to the directory containing Boost libraries or BOOST_ROOT
  to the location of Boost.

Call Stack (most recent call first):
CMakeLists.txt:6 (find_package)
-- Configuring incomplete, errors occurred!
See also "/home/devajji/ros_catkin_ws/build_isolated/tf2/CMakeFiles/CMakeOutput.log".
See also "/home/devajji/ros_catkin_ws/build_isolated/tf2/CMakeFiles/CMakeError.log".
<== Failed to process package 'tf2': 
 Command '['/home/devajji/ros_catkin_ws/install_isolated/env.sh', 'cmake', '/home/devajji/ros_catkin_ws/src/geometry2/tf2', 
'-DCATKIN_DEVEL_PREFIX=/home/devajji/ros_catkin_ws/devel_isolated/tf2', '- 
  DCMAKE_INSTALL_PREFIX=/home/devajji/ros_catkin_ws/install_isolated', '-DCMAKE_BUILD_TYPE=Release', '-DSETUPTOOLS_DEB_LAYOUT=OFF', '-G', 'Unix Makefiles']' returned non-zero exit status 1

Reproduce this error by running:
==> cd /home/devajji/ros_catkin_ws/build_isolated/tf2 && /home/devajji/ros_catkin_ws/install_isolated/env.sh cmake 
/home/devajji/ros_catkin_ws/src/geometry2/tf2 - 
DCATKIN_DEVEL_PREFIX=/home/devajji/ros_catkin_ws/devel_isolated/tf2 - 
DCMAKE_INSTALL_PREFIX=/home/devajji/ros_catkin_ws/install_isolated -DCMAKE_BUILD_TYPE=Release -DSETUPTOOLS_DEB_LAYOUT=OFF -G 'Unix Makefiles'

Command failed, exiting.
edit retag flag offensive close merge delete

Comments

Can you please update your question with a link to the tutorial that you're referring to?

jayess gravatar imagejayess ( 2019-09-17 13:39:08 -0500 )edit

Please check the updated link in the question.

midas gravatar imagemidas ( 2019-09-17 13:51:49 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-09-17 14:03:32 -0500

Take a look at https://github.com/ros/geometry2/pull..., which removes the signals requirement. That change hasn't been released yet, but I'm pretty sure it addresses this error.

edit flag offensive delete link more

Comments

Thank you! This worked. Basically, all instances of signals had to be removed. I also encountered a boost_python library not found - This was fixed by changing this : find_package(Boost REQUIRED python) to this : find_package(Boost REQUIRED python27) If it still fails, delete everything and do the recommended installation, instead of the full installation.

midas gravatar imagemidas ( 2019-09-17 16:14:12 -0500 )edit

This worked for me as well, with the geometry2 library. However, I'm running into the same issues in the ros_comm library (message_filters and roscpp CMakeLists.txt files) and geometry (tf CMakeLists.txt). In case anyone else runs into this before ROS releases the fixes. Also the python issue mentioned above is found in vision_opencv library (cv_bridge CMakeLists.txt).

exoticdft gravatar imageexoticdft ( 2019-09-25 17:08:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-09-16 12:12:29 -0500

Seen: 101 times

Last updated: Sep 17