Ask Your Question
0

How can I Solve NetworkSetup Problem?

asked 2019-09-10 09:29:02 -0500

tonic-stark gravatar image

updated 2019-09-11 03:15:40 -0500

Error message:

Unable to contact my own server at [http://192.168.0.2:38315/].
This usually means that the network is not configured properly.

A common cause is that the machine cannot ping itself.  Please check
for errors by running:

    ping 192.168.0.2

For more tips, please see

    http://www.ros.org/wiki/ROS/NetworkSetup

The traceback for the exception was written to the log file
edit retag flag offensive close merge delete

Comments

2

Can you please give us some more information about what your setup is. Can you describe how you've setup your ROS environment, what lines you added to your .bashrc file, and what commands you ran to produce this error.

PeteBlackerThe3rd gravatar imagePeteBlackerThe3rd ( 2019-09-10 09:42:49 -0500 )edit

Also, did you follow the suggestion to check if the machine can ping itself???

mgruhler gravatar imagemgruhler ( 2019-09-11 01:34:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-09-12 09:23:39 -0500

Phgo gravatar image

updated 2019-09-12 09:57:05 -0500

This looks very similar to this issue. Maybe you have a similar configuration error?

It is not clear from your problem description whether this is a network issue or an configuration issue.

So the first thing I would suggest is to check for full connectivity using pin/netcat. Keep in mind that ROS requires full bi-directional connectivity between all pairs of machines, on all ports.

Moreover, make sure your ROS_MASTER_URI, ROS_HOSTNAME / ROS_IP are set correctly on all machines.

  • In general ROS_MASTER_URI has to be set on each remote machine toROS_MASTER_URI=http://<hostname>:<used port> or http://<master ip>:<used port>
  • On the machine running the master you do not necessarily have to set ROS_MASTER_URI as it defaults to http://localhost:11311, however, if using a custom port (as in your case) set it to http://localhost:<used port>
  • ROS_HOSTNAMEonly has to be set manually on a machine if your systems default host names is not resolvable.
  • Alternatively to avoid taking care of the name resolution you can set ROS_IP to your external IP Address on each machine without a resolvable host name.

A basic tutorial on how to test and setup your network for ROS can be found here.

For a more specific answer please provide more details about your network configuration and your ROS environment.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-09-10 09:29:02 -0500

Seen: 71 times

Last updated: Sep 12