Ask Your Question
0

rosmake , build problems

asked 2012-05-03 07:39:38 -0500

Astronaut gravatar image

Hello

I installed diamondback ROS on my VIrtual Ubunti machine. Tried to build the beginner_tutorials package with rosmake but . I couldnt errors occurred. I got something like this:

zeus@zeus-laptop:~/ros_tutor/beginner_tutorials$ rosmake beginner_tutorials [ rosmake ] Packages requested are: ['beginner_tutorials']
[ rosmake ] Logging to directory/home/zeus/.ros/rosmake/rosmake_output-20120503-192420 [ rosmake ] Expanded args ['beginner_tutorials'] to: ['beginner_tutorials']
[ rosmake ] Checking rosdeps compliance for packages beginner_tutorials. This may take a few seconds. [ rosmake ] rosdep check passed all system dependencies in packages
[rosmake-0] Starting >>> roslib [ make ]
[rosmake-0] Finished <<< roslib ROS_NOBUILD in package roslib
[rosmake-0] Starting >>> std_msgs [ make ]
[rosmake-0] Finished <<< std_msgs ROS_NOBUILD in package std_msgs
[rosmake-0] Starting >>> rosgraph_msgs [ make ]
[rosmake-0] Finished <<< rosgraph_msgs ROS_NOBUILD in package rosgraph_msgs
[rosmake-0] Starting >>> rosbuild [ make ]
[rosmake-0] Finished <<< rosbuild ROS_NOBUILD in package rosbuild No Makefile in package rosbuild [rosmake-0] Starting >>> roslang [ make ]
[rosmake-0] Finished <<< roslang ROS_NOBUILD in package roslang No Makefile in package roslang [rosmake-0] Starting >>> rospy [ make ]
[rosmake-0] Finished <<< rospy ROS_NOBUILD in package rospy
[rosmake-0] Starting >>> cpp_common [ make ]
[rosmake-0] Finished <<< cpp_common ROS_NOBUILD in package cpp_common
[rosmake-0] Starting >>> roscpp_traits [ make ]
[rosmake-0] Finished <<< roscpp_traits ROS_NOBUILD in package roscpp_traits
[rosmake-0] Starting >>> rostime [ make ]
[rosmake-0] Finished <<< rostime ROS_NOBUILD in package rostime
[rosmake-0] Starting >>> roscpp_serialization [ make ]
[rosmake-0] Finished <<< roscpp_serialization ROS_NOBUILD in package roscpp_serialization [rosmake-0] Starting >>> xmlrpcpp [ make ]
[rosmake-0] Finished <<< xmlrpcpp ROS_NOBUILD in package xmlrpcpp
[rosmake-0] Starting >>> rosconsole [ make ]
[rosmake-0] Finished <<< rosconsole ROS_NOBUILD in package rosconsole
[rosmake-0] Starting >>> roscpp [ make ]
[rosmake-0] Finished <<< roscpp ROS_NOBUILD in package roscpp
[rosmake-0] Starting >>> beginner_tutorials [ make ]
[ rosmake ] All 16 lineseginner_tutorials: 2.4 sec ] [ 1 Active 14/15 Complete ] {------------------------------------------------------------------------------- mkdir -p bin cd build && cmake -Wdev -DCMAKE_TOOLCHAIN_FILE=rospack find rosbuild/rostoolchain.cmake .. CMake Error at build/CMakeFiles/CMakeSystem.cmake:1 (INCLUDE): include could not find load file:

  /opt/ros/cturtle/ros/core/rosbuild/rostoolchain.cmake

Call Stack (most recent call first):

[rosbuild] Building package beginner_tutorials [rosbuild] Including /opt/ros/diamondback/stacks/ros_comm/clients/rospy/cmake/rospy.cmake [rosbuild] Including /opt/ros/diamondback/stacks/ros_comm/clients/roslisp/cmake/roslisp.cmake [rosbuild] Including /opt/ros/diamondback/stacks/ros_comm/clients/cpp/roscpp/cmake/roscpp.cmake -- Configuring incomplete, errors occurred! -------------------------------------------------------------------------------} [ rosmake ] Output from build of package beginner_tutorials written to: [ rosmake ] /home/zeus/.ros/rosmake/rosmake_output-20120503-192420/beginner_tutorials/build_output.log [rosmake-0] Finished <<< beginner_tutorials [FAIL] [ 2.50 seconds ]
[ rosmake ] Halting due to failure in package beginner_tutorials. [ rosmake ] Waiting for other threads to complete. [ rosmake ] Results:
[ rosmake ] Built 15 packages with 1 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /home/zeus/.ros/rosmake/rosmake_output-20120503-192420
zeus@zeus-laptop:~/ros_tutor/beginner_tutorials$

Can you help me please? also roscore does not initialize. Any advice?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-05-03 07:45:55 -0500

michikarg gravatar image

It seems like something in your configuration is pointing to a cturtle installation of ROS. Did you have a previous installation of cturtle on your machine? Or do you have a parallel cturtle-installation somewhere?

edit flag offensive delete link more

Comments

Btw. why do you want to use diamondback? Is ROS Electric no option for you?

michikarg gravatar image michikarg  ( 2012-05-03 07:46:35 -0500 )edit
0

answered 2012-05-03 08:12:19 -0500

Astronaut gravatar image

updated 2012-05-03 08:37:29 -0500

Well im beginner on this. I do not have other cturtle-instalation. I just wonted to understand the middleware framework, how to subscribe/publish to topics, write simple apps and drivers, use rosbag for replaying data, rviz, etc. So why ROS Electric is better otion? I got already installed ROS diamondback and i just played the beginner_tutorials on my oracle VM box. My project is on Willow Garage ROS based.

Any sugestions?

P.S rosrun turtlesim turtlesim_node is working perfect . Also rosrun turtlesim turtlesim_node. But the $ rxgraph failed. Connections errors. Like this

Unable to contact master [Errno 111] Connection refused

edit flag offensive delete link more

Comments

ROS Diamondback is really old. Fuerte has recently been released and I don't think Diamondback is still supported. As Michi already pointed out, your installation seems to be messed up. Follow the instructions at http://www.ros.org/wiki/fuerte/Installation/Ubuntu and the tutorials.

Lorenz gravatar image Lorenz  ( 2012-05-03 09:03:06 -0500 )edit

But when diamondback is old does not means that is still not working. So any chance to upgrade to Fuerte or Electric?

Astronaut gravatar image Astronaut  ( 2012-05-04 01:35:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-03 07:39:38 -0500

Seen: 686 times

Last updated: May 03 '12