Ask Your Question
0

Turtlebot Dashboard not coming up.

asked 2012-05-02 07:49:46 -0500

njavia66 gravatar image

Hello,

I have a problem with turtlebot dashboard not popping up on the screen. When I run the command:

rosrun turtlebot_dashboard turtlebot_dashboard

I get a message that looks like this:

Unable to register with master node [http://143.215.120.237:11311]: master may not be running yet. Will keep trying

One time it actually ran the dashboard and everything was greyed out. The tutorial said that the ROS_MASTER_URI must not be set correctly but it is.

I am pinging to the turtlebot, turtlebot is on, and I have ssh'ed in to it already. (I don't know if any of this makes a difference)

Although, when I roscore on MY laptop it give me an error saying:

WARNING: ROS_MASTER_URI [http://143.215.120.237:11311] host is not set to this machine

I have made an edit in my .bashrc to run the correct ROS_MASTER_URI.

What can I do for my dashboard to pop up correctly?

Thanks in advance! :D

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-05-02 07:55:11 -0500

karthik gravatar image

updated 2012-05-02 08:54:55 -0500

Hi, This error says that the roscore is not running. Please run

roscore

on the turtlebot system before you start the dashboard. Hope it helps


Please cross check the tutorials if everything is correct. This definitely has to do with the roscore only as the error clearly mentions the master is not available. It could also be the networking issue as the roscore running on the turtlebot is not detected by the workstation. Please cross check with the setup and test the networking with the testing procedure i have mentioned in this answer. Hope it helps


Check three places where you might have to check the setup

  1. /etc/hosts

  2. ~/.bashrc

  3. ~/ros_workspace/setup.h

Check for the MASTER_URI and HOST_URI in the ~/.bashrc

Karthik

edit flag offensive delete link more

Comments

When I run it I still get that warning like I showed above. Does that matter?

njavia66 gravatar image njavia66  ( 2012-05-02 07:57:25 -0500 )edit

I just tried running roscore then bringing up turtlebot_dashboard but I got no luck

njavia66 gravatar image njavia66  ( 2012-05-02 07:58:09 -0500 )edit

Okay so when I run the roscore. It gives me the error again and under it says the OLD ROS_MASTER_URI. How do I re-write it using commands? I have used the one provided on tutorials but it does not seem to do it. I have also over-wrote on the .bashrc but it seems to night have recognised it.

njavia66 gravatar image njavia66  ( 2012-05-02 08:17:34 -0500 )edit
1

I am pretty sure you have done some mistake in the network setup as mentioned in the tutorials. Please check them back carefully. You might have interchanged the settings from the workstation the turtlebot or the otherway around.

karthik gravatar image karthik  ( 2012-05-02 08:44:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-05-02 07:49:46 -0500

Seen: 827 times

Last updated: May 02 '12