Gazebo crashing when trying to open model

asked 2019-08-04 10:46:54 -0500

amstrudy gravatar image

updated 2019-08-04 10:47:25 -0500

I'm working through the URDF tutorials here but I am having trouble with Gazebo. Here is a minimal example:

URDF file (called como.xacro)

<?xml version="1.0" ?>

<robot name="como" xmlns:xacro="http://www.ros.org/wiki/xacro">

  <xacro:property name="PI" value="3.14159265358979"/>
  <xacro:property name="HALF_PI" value="1.57079632679"/>

  <xacro:property name="CHASSIS_HEIGHT" value="0.3"/>
  <xacro:property name="CHASSIS_WIDTH" value="0.2"/>
  <xacro:property name="CHASSIS_LENGTH" value="0.5"/>
  <xacro:property name="CHASSIS_MASS" value="2"/>
  <xacro:property name="CHASSIS_HALF_HEIGHT" value="0.15"/>

  <xacro:property name="WHEEL_RADIUS" value="0.08"/>
  <xacro:property name="WHEEL_WIDTH" value="0.03"/>
  <xacro:property name="WHEEL_POS_X"  value="0.15"/>
  <xacro:property name="WHEEL_POS_Y"  value="0.1"/>
  <xacro:property name="WHEEL_MASS"  value="0.3"/>

  <link name="base_link">
    <visual>
    <origin xyz="0 0 ${CHASSIS_HALF_HEIGHT}" rpy="0 0 0"/>
    <geometry>
      <box size="${CHASSIS_LENGTH} ${CHASSIS_WIDTH} ${CHASSIS_HEIGHT}"/>
    </geometry>
    <material name="orange"/>
    </visual>
    <collision>
      <origin xyz="0 0 ${CHASSIS_HALF_HEIGHT}" rpy="0 0 0"/>
      <geometry>
        <box size="${CHASSIS_LENGTH} ${CHASSIS_WIDTH} ${CHASSIS_HEIGHT}"/>
      </geometry>
    </collision>
    <intertial>
      <origin xyz="0 0 ${CHASSIS_HALF_HEIGHT}" rpy="0 0 0"/>
      <mass value="${CHASSIS_MASS}"/>
      <inertia ixx="0.01" ixy="0.01" ixz="0.01" iyy="0.01" iyz="0.01" izz="0.01"/>
    </intertial>
  </link>

  <gazebo>
    <plugin name="gazebo_ros_control" filename="libgazebo_ros_control.so">
      <robotNamespace></robotNamespace>
    </plugin>
  </gazebo>
</robot>

And here is my launch file gazebo.launch:

<launch>

  <!-- Gazebo -->
  <arg name="paused" default="false"/>
  <arg name="use_sim_time" default="true"/>
  <arg name="gui" default="true"/>
  <arg name="headless" default="false"/>
  <arg name="debug" default="false"/>
  <arg name="model" default="$(find como_description)/urdf/como.xacro"/>

  <include file="$(find gazebo_ros)/launch/empty_world.launch">
    <arg name="debug" value="$(arg debug)" />
    <arg name="gui" value="$(arg gui)" />
    <arg name="paused" value="$(arg paused)"/>
    <arg name="use_sim_time" value="$(arg use_sim_time)"/>
    <arg name="headless" value="$(arg headless)"/>
  </include>

  <param command="$(find xacro)/xacro $(arg model)" name="robot_description"/>

  <node name="urdf_spawner" pkg="gazebo_ros" type="spawn_model"
        args="-z 1.0 -unpause -urdf -model como -param robot_description" respawn="false" output="screen"/>

  <!-- Combine joint values -->
  <node name="robot_state_publisher" pkg="robot_state_publisher" type="state_publisher"/>

</launch>

I am getting this error:

gzclient: /build/ogre-1.9-B6QkmW/ogre-1.9-1.9.0+dfsg1/OgreMain/include/OgreAxisAlignedBox.h:252: void Ogre::AxisAlignedBox::setExtents(const Ogre::Vector3&, const Ogre::Vector3&): Assertion '(min.x <= max.x && min.y <= max.y && min.z <= max.z) && "The minimum corner of the box must be less than or equal to maximum corner"' failed. Aborted (core dumped)

I looked all over the place and found that this was supposed to have been fixed with some gazebo patch, so I made sure all of my packages and such were updated (I am running Gazebo 9.0.0), and that didn't fix ... (more)

edit retag flag offensive close merge delete

Comments

I'm also getting the same error ! Need help guys!

pmuthu2s gravatar imagepmuthu2s ( 2019-08-05 08:11:03 -0500 )edit