ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

Accidentaly deteled python2.7 and roscore is dead [closed]

asked 2019-08-01 12:11:20 -0500

fish24 gravatar image

updated 2019-08-01 12:55:31 -0500

gvdhoorn gravatar image

Hi! I have accidentally deleted python2.7 and now I can't run roscore. I tried to reinstall it but..

^C... logging to /home/fish/.ros/log/b4e7951a-b47d-11e9-9717-9cb6d08c99cd/roslaunch-fish-XPS-13-9370-6045.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

^CTraceback (most recent call last):
  File "/opt/ros/kinetic/bin/roscore", line 70, in <module>
    roslaunch.main(['roscore', '--core'] + sys.argv[1:])
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 306, in main
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 268, in start
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunc

h/", line 226, in _start_infrastructure
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 177, in _start_server
  File "/opt/ros/kinetic/lib/python2.7/dist-packages/roslaunch/", line 376, in start
    code, msg, val = ServerProxy(self.uri).get_pid()
  File "/usr/lib/python2.7/", line 1243, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib/python2.7/", line 1602, in __request
  File "/usr/lib/python2.7/", line 1283, in request

    return self.single_request(host, handler, request_body, verbose)
      File "/usr/lib/python2.7/", line 1311, in single_request
        self.send_content(h, request_body)
      File "/usr/lib/python2.7/", line 1459, in send_content
      File "/usr/lib/python2.7/", line 1053, in endheaders
  File "/usr/lib/python2.7/", line 897, in _send_output
  File "/usr/lib/python2.7/", line 859, in send
  File "/usr/lib/python2.7/", line 836, in connect
self.timeout, self.source_address)
  File "/usr/lib/python2.7/", line 566, in create_connection
      File "/usr/lib/python2.7/", line 228, in meth
        return getattr(self._sock,name)(*args)

Please help! How can I repair it?

Ubuntu Xenial ROS Kinetic

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by fish24
close date 2019-08-02 03:54:58.264666

1 Answer

Sort by ยป oldest newest most voted

answered 2019-08-01 12:51:57 -0500

Well, those errors are more deeper than I thought...

I had experiences with this (most because of Open CV old version installed with Kinetic). My solution was to uninstall ROS, everything from python and then reinstall it. I recommend to uninstall ROS following this:

sudo apt-get purge '^ros-*'
sudo apt-get autoremove

and then installing again (after python 2.7)

Try this and tell me later, best regards

edit flag offensive delete link more


It worked. I had some problems ("<package> is not installed, so not removed") but I managed to solve them manually deleting the ROS folder from /etc. Thank you!

fish24 gravatar image fish24  ( 2019-08-02 03:59:14 -0500 )edit

Glad that I could helped!

kaike_wesley_reis gravatar image kaike_wesley_reis  ( 2019-08-02 05:42:25 -0500 )edit

Question Tools



Asked: 2019-08-01 12:11:20 -0500

Seen: 289 times

Last updated: Aug 01 '19