launch_test command not found

asked 2019-07-29 06:33:18 -0600

hect1995 gravatar image

updated 2019-07-29 06:53:24 -0600

I want to launch several nodes and check that the output of one specific node is something that I know in advance. ROS community recently added launch_testing(https://github.com/ros2/launch/tree/m...) but whenever I run launch_test in my command line it does not detect the command, neither in my ROS2 crystal nor in my dashing. I have ROS2 sourced and I can call other commands like ros2 run. If I check with ros2 pkg list it appears just the launch package. I have tried to clone the whole launch repo from Github but still just appears launch.

Moreover, I would like to know if it would be possible to check the output of a topic instead of the process outputs and exit codes.

My launch_descriptor looks like this:

def generate_test_description():
    ld = LaunchDescription([
        Node(package='gui_pkg', node_executable='process_node', output='screen'),
        Node(package='planning_prob_pkg', node_executable='planning_prob_node', output='screen'),
        Node(package='planner_pkg', node_executable='planner_node', output='screen'),
        Node(package='simulation_pkg', node_executable='simulation_node', output='screen'),
        Node(package='state_machine_pkg', node_executable='state_machine_node', output='screen')
    ])
    return ld

And would like to test that a message published in the node executable simulation_node is some value that I know in advance.

edit retag flag offensive close merge delete