Ask Your Question
1

Failed to find rosdep joystick for package teleop_base on OS.....

asked 2012-04-29 11:47:11 -0500

chenling34401 gravatar image

updated 2014-01-28 17:12:09 -0500

ngrennan gravatar image

Hi, all, I was trying to follow the tutorial on simulating one robot using stage(link text), when I run "rosmake teleop_base", it pop up the following errors: Failed to find rosdep joystick for package teleop_base on OS:ubuntu version:oneiric [ rosmake ] rosdep check failed to find system dependencies: joystick

I tried to find the joystick dependency on ROS website, but I could not find it.

Can any one give a solution to this problem? Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2012-04-29 17:14:57 -0500

Since you're using Ubuntu, you should use the binary packages, rather than installing from source. sudo apt-get install ros-electric-simulator-stage ros-electric-joystick-drivers I think should install everything you need.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-04-29 11:47:11 -0500

Seen: 491 times

Last updated: Apr 29 '12