Check if you started movegroups

asked 2019-07-09 13:09:50 -0500

Gates gravatar image

I am trying to learn MoveIt and do some test on UR5. At this step I am trying to control UR5 with joystick. I followed Joystick Control Teleoperation. I can plan and execute with my UR5 without any problem. However when I run joystick_control.launch, I get the problem "Check if you started movegroups. Exiting."

I started the move group (with demo.launch):

rostopic list
/move_group/cancel
/move_group/display_contacts
/move_group/display_cost_sources
/move_group/display_grasp_markers
/move_group/display_planned_path
/move_group/fake_controller_joint_states
/move_group/feedback
/move_group/goal
/move_group/monitored_planning_scene
/move_group/motion_plan_request
/move_group/ompl/parameter_descriptions
/move_group/ompl/parameter_updates
/move_group/plan_execution/parameter_descriptions
/move_group/plan_execution/parameter_updates
/move_group/planning_scene_monitor/parameter_descriptions
/move_group/planning_scene_monitor/parameter_updates
/move_group/result
/move_group/sense_for_plan/parameter_descriptions
/move_group/sense_for_plan/parameter_updates
/move_group/status
/move_group/trajectory_execution/parameter_descriptions
/move_group/trajectory_execution/parameter_updates

I believe that I miss a point in introducing the group name to joystick somehow. I was thinking that moveit setup assistant does it automatically because I am running the demo.launch which was created by the assistant. Also I am running the joystick_controller.launch created by the assistant, too. I have no idea where is the problem.

edit retag flag offensive close merge delete

Comments

You don't seem to be the only one with that problem. I tried with 2 setups and also found an issue on GitHub.

pcoenen gravatar imagepcoenen ( 2019-07-10 10:16:43 -0500 )edit

I am not sure if it is a bug or I did miss something because when I created a new clean XXX_moveit_config package, it works fine with the joystick. So, probably I missed a parameter of group name in somewhere. I don't know where it was. I want to know how the joystick catches the group name, honestly. In the moveitjoy_module.py, I see only the end effector link name is catched, not a group name.

Gates gravatar imageGates ( 2019-07-10 11:24:57 -0500 )edit