camera_calibration display freezes

asked 2019-07-08 04:14:53 -0600

kevthomson gravatar image

I run a cv_camera node as

rosrun cv_camera cv_camera_node /cv_camerimage_raw:=/cv_camera/

then camera_calibration as

rosrun camera_calibration cameracalibrator.py --size 8x7 --square 0.025 image:=/cv_camera/image_raw camera:=/cv_camera

It then says ('Waiting for service', '/cv_camera/set_camera_info', '...') OK

the display window that's supposed to give a grayscale video stream then just freezes.

It used to work until after many tries of pointing the chessboard at the webcam didn't result in the "Calibrate" button not being greyed out. I then tried to disable auto_focus on my webcam as a way of troubleshooting this, but my webcam Logitech C270 didn't seem to have auto focus as a modifiable property (no focus_auto). I did set exposure_auto to 1 using v4l-utils in hopes of activating calibration, but the value seems to reset to 3 after each system restart. Speaking of, my Ubuntu 16.04 OS is in pair with a Windows installation in dual-boot, if it matters.

edit retag flag offensive close merge delete