ros1_bridge installation error

asked 2019-07-02 05:06:33 -0500

kk2105 gravatar image

updated 2019-07-11 23:36:15 -0500

Hi Guys,

I have recently started working on ROS2 platform. And I want to create bridge between ROS1 and ROS2.

I have installed ROS2 dashing and proceeded with the installation of ros1_bridge.

Below are procedure:

sh -c 'echo "deb $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list' apt-key adv --keyserver 'hkp://' --recv-key C1CF6E31E6BADE8868B172B4F42ED6FBAB17C654 sudo apt update apt install ros-dashing-ros1-bridge
However I am getting the below error, which results in un-successful installation.

Fetched 74.3 MB in 1min 58s (629 kB/s) E: Failed to fetch Connection failed [IP: 80] E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Tried switching servers in ubuntu and softwares but did not help.
I am able to access the failed link and download the package using web browser.

Update 1:
Updating the apt-get update output

system@laptop:/module$ sudo apt-get update
Hit:1 bionic InRelease
Hit:2 bionic InRelease                                     
Get:3 bionic-updates InRelease [88.7 kB]                      
Get:4 bionic InRelease [3,209 B]                           
Get:5 bionic-security InRelease [88.7 kB]                    
Get:6 bionic-backports InRelease [74.6 kB]
Get:7 bionic-updates/main amd64 Packages [886 kB]             
Get:8 bionic/main amd64 Packages [344 kB]               
Get:9 bionic-security/universe amd64 Packages [722 kB]    
Get:10 bionic-updates/universe amd64 Packages [1,240 kB]   
Get:11 bionic-security/main amd64 Packages [578 kB]
Get:12 bionic/main arm64 Packages [331 kB]
Fetched 4,357 kB in 6s (779 kB/s)  
Reading package lists... Done


Update 2:

Output of curl command.

 system@laptop:/module$ curl -v --output libboost.deb
   % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                             Dload  Upload   Total   Spent    Left  Speed
   0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0*   Trying
 * Connected to ( port 80 (#0)
 > GET /ubuntu/pool/main/b/boost1.65.1/libboost1.65-dev_1.65.1+dfsg-0ubuntu5_amd64.deb HTTP/1.1
 > Host:
 > User-Agent: curl/7.58.0
 > Accept: */*
  0     0    0     0    0     0      0      0 --:--:--  0:00:12 --:--:--     0* Empty reply from server
  0     0    0     0    0     0      0      0 --:--:--  0:00:12 --:--:--     0
 * Connection #0 to host left intact
 curl: (52) Empty reply from server

Thank you, KK

edit retag flag offensive close merge delete


Can you please check whether you're running into #q325039?

What is the output of sudo apt update?

gvdhoorn gravatar image gvdhoorn  ( 2019-07-02 09:43:10 -0500 )edit

did you try building it from source?

pavel92 gravatar image pavel92  ( 2019-07-03 03:09:35 -0500 )edit

@gvdhoorn Thanks for the response and apologies for the delayed response. It doesn't seem like the issue I am facing issue related to #q325039. For example I can access the link However I am not able to download the file libboost1.65-dev_1.65.1+dfsg-0ubuntu5_amd64.deb .
Thank you.

kk2105 gravatar image kk2105  ( 2019-07-11 07:14:03 -0500 )edit

@pavel92 I have not tried building from source. Ultimately I want to create a docker image, so it would be easy if I can install it using apt-get install
Thank you.

kk2105 gravatar image kk2105  ( 2019-07-11 07:15:33 -0500 )edit

What is the output of sudo apt update? I still think you're running into #q325039: apt trying to download "old versions" of .deb packages is exactly one of the symptoms of it.

gvdhoorn gravatar image gvdhoorn  ( 2019-07-11 08:12:28 -0500 )edit

@gvdhoorn I have updated the question with the apt-get update. Could you please let me know how can I skip those old files if it is looking for the old files which dont exist.

Thank you.

kk2105 gravatar image kk2105  ( 2019-07-11 22:20:52 -0500 )edit

@gvdhoorn I have also tried updating the new keys, but still no luck.

kk2105 gravatar image kk2105  ( 2019-07-11 22:22:32 -0500 )edit

@kk2105 can you please try curl -v --output libboost.deb and give us the output?

soroosh129 gravatar image soroosh129  ( 2019-07-11 23:19:49 -0500 )edit