Map transform not published by AMCL.

asked 2019-06-27 11:39:04 -0500

sajal gravatar image

In my tf tree, map transform is not published. I only have odom<-base_link>-base_laser. I'm using navigation stack package and I have only added "use_map_topic" parameter to true, base_frame_id to base_link and global_frame_id to map in the amcl_omni.launch file. I'm using map_server to publish map and getting map and metadata topics. My amcl launch file runs good and shows no error. (pose array and pose with covariance are published). Is there a way to publish map>-odom tf?

edit retag flag offensive close merge delete

Comments

It's either amcl which is configured to hold the map file path that is published or a file such as move_base that connects all the map configuration parameters (such as global, local, costmaps etc) and launches both amcl with the mentioned map parameters that are required. Do you have a setup close to this?

spiritninja gravatar imagespiritninja ( 2019-06-27 23:02:59 -0500 )edit