Ask Your Question
0

Planner is not working for Baxter simulator in Rviz and with Moveit

asked 2019-06-18 21:59:34 -0500

Tawfiq Chowdhury gravatar image

I installed Baxter and Moveit simulator to work with Baxter as said here. However, I am having an issue, the planner is neither working in Rviz if I just drag the interactive marker and then plan nor if I run this tutorial. It keeps failing when I drag the marker in Rviz and then plan and when I run the tutorial code, it keeps saying no motion plan found.

My PC also hangs after running the Gazebo and Rviz together for about 5 minutes, it has 16 gigabytes of RAM with a core i7 processor. So, capacity of the computer should not be an issue.

edit retag flag offensive close merge delete

Comments

@Geoff could you please help?

Tawfiq Chowdhury gravatar imageTawfiq Chowdhury ( 2019-06-18 22:00:11 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-06-19 16:01:47 -0500

Tawfiq Chowdhury gravatar image

I figured it out, after running the commands from Baxter simulator tutorial, you first need to run the following commands in two separate terminals from this tutorial :

rosrun baxter_tools enable_robot.py -e
rosrun baxter_interface joint_trajectory_action_server.py

Then you need to select command "With Electric Gripper(s)" and run the following command:

roslaunch baxter_moveit_config baxter_grippers.launch
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2019-06-18 21:59:34 -0500

Seen: 22 times

Last updated: Jun 19