Ask Your Question
0

getting error when I install ros-kinetic-rosbridge-suite on ubuntu 16

asked 2019-06-04 02:32:27 -0500

amart gravatar image

updated 2019-06-06 02:31:43 -0500

gvdhoorn gravatar image

Can anyone please suggest me?

:~$ echo $ROS_DISTRO
kinetic
:~$ sudo apt install ros-kinetic-rosbridge-suite
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ros-kinetic-rosbridge-suite

Edit: The output:

:~$ cat /etc/apt/sources.list.d/ros-latest.list
deb http://packages.ros.org/ros/ubuntu precise main
edit retag flag offensive close merge delete

Comments

Can you install other ROS pkgs using apt? What is the output of uname -a? Have you ran sudo apt update recently?

gvdhoorn gravatar imagegvdhoorn ( 2019-06-04 02:39:34 -0500 )edit

i've run sudo apt update. I can't install any ros package.

amart gravatar imageamart ( 2019-06-06 00:58:18 -0500 )edit

If you can't install any ROS packages then I would guess you haven't setup your system correctly.

Which installation guides (if any) did you follow?

What is the output of

cat /etc/apt/sources.list.d/ros-latest.list
gvdhoorn gravatar imagegvdhoorn ( 2019-06-06 02:25:29 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-06-06 02:34:43 -0500

gvdhoorn gravatar image

Edit: The output:

:~$ cat /etc/apt/sources.list.d/ros-latest.list
deb http://packages.ros.org/ros/ubuntu precise main

The problem most likely is that you've configured your system to ask the ROS package repositories for Ubuntu Precise (ie: 14.04) while you are actually running Ubuntu Xenial (16.04) -- or at least according to your question title.

I'm not sure how that happened, but you should be able to correct this situation using the following command:

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'

Note that this will override whatever you have now in /etc/apt/sources.list.d/ros-latest.list.

Did you follow the installation tutorial for ROS Kinetic on Ubuntu Xenial?

edit flag offensive delete link more

Comments

Yes I followed http://wiki.ros.org/kinetic/Installat... for Ros Kinetic on Ubuntu Xenial. After I run this comment

sudo sh -c 'echo "deb http://packages.ros.org/ros/ubuntu $(lsb_release -sc) main" > /etc/apt/sources.list.d/ros-latest.list'

The output has overridden which resulted is :

deb http://packages.ros.org/ros/ubuntu xenial main

But cannot install rosbridge package yet. Any other suggestion please?

amart gravatar imageamart ( 2019-06-06 02:53:38 -0500 )edit

Did you run sudo apt-get update before trying to install again?

gvdhoorn gravatar imagegvdhoorn ( 2019-06-06 02:55:03 -0500 )edit

After running sudo apt-get update and try to install again, now it perfectly worked. Thank a lot you saved my time.

amart gravatar imageamart ( 2019-06-06 03:00:26 -0500 )edit

Sure. Done sir

amart gravatar imageamart ( 2019-06-06 03:10:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2019-06-04 02:32:27 -0500

Seen: 363 times

Last updated: Jun 06