Ask Your Question
0

error compiling roboearth

asked 2012-04-24 03:26:54 -0600

Gaëtan gravatar image

Hi,

i'm trying to install roboearth, folowing this instructions : http://www.ros.org/wiki/roboearth

The installation through roboearth.rosinstall goes well.

But when I try to compile it with rosmake roboearth, I get this error message :

-- Configuring incomplete, errors occurred! -------------------------------------------------------------------------------} [ rosmake ] Output from build of package re_comm written to: [ rosmake ] /home/gseverac/.ros/rosmake/rosmake_output-20120424-152010/re_comm/build_output.log [rosmake-1] Finished <<< re_comm [FAIL] [ 0.11 seconds ]
[rosmake-2] Starting >>> eigen [ make ]
[ rosmake ] Halting due to failure in package re_2dmap_extractor. [ rosmake ] Waiting for other threads to complete. [ rosmake ] Halting due to failure in package re_comm. [ rosmake ] Waiting for other threads to complete. [rosmake-2] Finished <<< eigen ROS_NOBUILD in package eigen
[ rosmake ] Results:
[ rosmake ] Built 23 packages with 2 failures.
[ rosmake ] Summary output to directory
[ rosmake ] /home/gseverac/.ros/rosmake/rosmake_output-20120424-152010
[ rosmake ] WARNING: Rosdep did not detect the following system dependencies as installed: swi_prolog_sgml, swi_prolog_clib, libjson_java, swi_prolog_http, swi_prolog_xpce, swi_prolog_odbc, swi_prolog_semweb, swi_prolog Consider using --rosdep-install option or rosdep install re_kinect_object_detector re_object_detector_gui ar_bounding_box re_object_recorder re_2dmap_extractor re_ontology re_srvs re_vision re_msgs re_comm

then when I try rosdep install re_kinect_object_detector re_object_detector_gui ar_bounding_box re_object_recorder re_2dmap_extractor re_ontology re_srvs re_vision re_msgs re_comm

I get the error :

ERROR: Rosdep cannot find all required resources to answer your query Missing resource mod_probcog

and then I'm stuck ...

Do you have an idea of what i can try or test ?

Thanks,

Gaëtan

edit retag flag offensive close merge delete

Comments

Please also provide the distribution and Ubuntu version you are using.

Bence Magyar gravatar imageBence Magyar ( 2012-04-24 04:07:02 -0600 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2012-04-24 05:55:04 -0600

Gaëtan gravatar image

It's working know

executing :

apt-get install ros-electric-client-rosjava-jni

and

apt-get install libjson-glib-dev

then specifying the https_proxy=xxx in front of the rosmake roboearth command

For info and answer i use Ubuntu 10.04 LTS.

Gaëtan

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-04-24 03:26:54 -0600

Seen: 406 times

Last updated: Apr 24 '12