Ask Your Question
0

[BLAM] catkin_make_isolated: command not found

asked 2019-05-22 08:51:31 -0500

hachbani gravatar image

updated 2019-05-22 08:52:57 -0500

gvdhoorn gravatar image

Hi, I've been struggling for days to setup BLAM!, Let me provide you with the maximum of information you might need :

my ROS_PACKAGE_PATH is set to /opt/ros/kinetic/share. I did remove the catkin_ws path.

I cloned the project to my home folder and tried the same with creating a folder in home and cloning the project into this folder. Same bug.

THE BUG:

When I type sudo ./update (Without the sudo I get a lot of permission denied errors, ergo, the sudo) I get the following errors (the error in pastebin)

Creating a ROS workspace for third party packages.
Merge caused no change, no new elements found
./update: line 13: catkin_make_isolated: command not found
Creating a ROS workspace for BLAM packages.
Merge caused no change, no new elements found
[blam_example] Updating /home/hamza/blam/internal/src/blam_example
[blam_example] Done.
[blam_slam] Updating /home/hamza/blam/internal/src/blam_slam
[blam_slam] Done.
[geometry_utils] Updating /home/hamza/blam/internal/src/geometry_utils
[geometry_utils] Done.
[laser_loop_closure] Updating /home/hamza/blam/internal/src/laser_loop_closure
[laser_loop_closure] Done.
[measurement_synchronizer] Updating /home/hamza/blam/internal/src/measurement_synchronizer
[measurement_synchronizer] Done.
[parameter_utils] Updating /home/hamza/blam/internal/src/parameter_utils
[parameter_utils] Done.
[point_cloud_filter] Updating /home/hamza/blam/internal/src/point_cloud_filter
[point_cloud_filter] Done.
[point_cloud_localization] Updating /home/hamza/blam/internal/src/point_cloud_localization
[point_cloud_localization] Done.
[point_cloud_mapper] Updating /home/hamza/blam/internal/src/point_cloud_mapper
[point_cloud_mapper] Done.
[point_cloud_odometry] Updating /home/hamza/blam/internal/src/point_cloud_odometry
[point_cloud_odometry] Done.
[point_cloud_visualizer] Updating /home/hamza/blam/internal/src/point_cloud_visualizer
[point_cloud_visualizer] Done.
[pose_graph_msgs] Updating /home/hamza/blam/internal/src/pose_graph_msgs
[pose_graph_msgs] Done.
./update: line 27: catkin_make: command not found
./update: line 28: /home/hamza/blam/internal/devel/setup.bash: No such file or directory

I'm not feeling optimistic about it at all, kind of tried every thread I've found. With no official documentation or tutorial, don't know how this is supposed to work...

Thanks !

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2019-05-22 10:54:17 -0500

This is going to sound silly, but have you installed catkin tools? can you run catkin_make on a workspace in your repo and have it work? Both instances of catkin tools failed in your log.

If it works, make the script work without sudo. Nothing I read in that script indicates to me that sudo should be required.

If that doesn't work, you got me. Make sure your paths are set up correctly, or if you're in a container environment there may be some additional steps required.

edit flag offensive delete link more

Comments

3

It's also possible that the OP hasn't source /opt/ros/kinetic/setup.bash before running the script.

I'm not sure why he is manually fiddling with ROS_PACKAGE_PATH. That should not be needed.

gvdhoorn gravatar image gvdhoorn  ( 2019-05-22 11:00:44 -0500 )edit

Thanks to the both of you for your answers.

I don't know why or how, the first I came in to my office this morning, I launched ./update without the sudo and it did work ! I did try it a dozens of time and it didn't work before.

To answer your question for people reading this thread in the futur: - The Catkin tools are installed correctly, I've been using them for months, when I use them in another workspace, they work, but when I type them in the BLAM_ws, it's an unknown command. Now the update file worked, I did source blam/internal/devel/setup.bash and it works.

  • I did source the /opt/ros/kinetic/setup.bash. Since I'm not an expert in ROS, I was using the ROS_PACKAGE_PATH to double check that there's no other path other than the /opt/ros/kinetic ...
(more)
hachbani gravatar image hachbani  ( 2019-05-23 03:49:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2019-05-22 08:51:31 -0500

Seen: 344 times

Last updated: May 22 '19